What is the size limit for Geotiff?


I tried to use a geotiff in MP 1.3.45 and got a System.OutOfMemoryException: Array dimensions exceeded supported range. etc. Geotiff.GetAltitude(…
What is the limit ? Can you(=@Michael_Oborne) make it bigger ? Or do I need more RAM ?

Thank You

are you on a 32 bit or 64 bit platform?
32 bit is limited to 2gb of memory

also how many pixel’s wide is your image?
I think the issue is actually that its to many pixel wide
if you split the file up I believe it would work

Hi Michael,

I am on W10 64bit, I can load a 1.7GB geotiff but it doesn’t work with 2.7GB.

how many pixels wide was the image?

I believe that is the limit you hit. not a memory one.

ok after looking harder.

you need to limit each geotiff to a max of 2gb. you can have more than one 2 gb file, but they must be bellow 2 gb.

for each 2gb file you load, it will use 2 gb of memory however

ok change of plans. I’m adding support for the 2.7gb file, but it will not be cached in memory. I’m not 100% sure what speed slow down this will have. but means that the 2.7gb file will work as is
ive uploaded a new beta MP.

could you test this?

I have tried this already with smaller files and it worked for me too.

I tried the 2.7GB geotiff with MP and it worked, THANK YOU !
It didn’t seem to be slower than the 1.7GB in practice (I have 6GB RAM).

One small thing: Within the boundaries of the GeoTiff I get the GeoTiff heights and outside I get the SRTM heights up to a frame size very roughly about 5x bigger the GeoTiff, but going even further away ‘Invalid 0.00m’ is displayed. This is ofcourse no problem in usage, just wanted to mention it as a hint for a possible problem.

Tried another GeoTiff with 3.17GB and it didn’t work, but this one was made using a lzw-compression algorithm.
Edit: tried another compressed GeoTiff with 2.43 GB, same thing, doesn’t show heights 'GeoTiff 0.00m’
Edit 2: tried the GeoTiff 3.17 GB(lzw compressed) without compression, got 5.32 GB and it worked

Old laptop, 32bit 1 GB RAM, W10, MP
GeoTiff 5.32 GB doesn’t work, everywhere ‘Invalid 0.00m’ in target area and outside, NO SRTM.
Console shows OutOfMemoryException as in post #1.

GeoTiff 2.66 GB same as above

GeoTiff 1.68 GB o.k., so 2 GB limit for 32 bit System seems to be active.

Tried three sub 2 GB files (1.18, 1.57, 1.68 GB):
they work as expected on the 64 bit system (seems to load faster than 1 big file of same area).
On the 32 bit 1 GB system the 1.68 GB works correct, the other two files not. When the mouse crosses the border to the 1.18 GB or 1.57 GB file, the last value in height and GeoTiff or SRTM is displayed and doesn’t change until the mouse exits the area.
Should the files overlap ? Any problems expected if the areas overlap ?
The 1.68 GB file works as single GeoTiff, the two smaller ones do not work (OutOfMemoryException). As you mentioned a possible width problem (the two smaller ones are a North and a South part), I tried a vertical cut to get an East and West slice. Unfortunately same result. The mystery for me is, that the 1.68 GB is the biggest one and has almost same width as the North section and it is wider than the South section.

While I have your attention, can I motivate you to improve the Survey Grid tool ? It is really lacking for flying in the mountains and I could tell you my ideas for necessary extensions - wouldn’t be too much work I hope.

32bit has a max memory of 2gb. no matter what you are trying to do.

64bit has a max of 2gb per object, which I can get around.

however the 32bit limit is one where all stuck with, ie multiple small files will fill the 2gb max

with your 32bit tests, what happens if they are all above 2gb? I believe this should work. as it wont try and cache in memory.
just make sure you are running the latest beta

I will try on Tuesday.

All test were done using MP

No, doesn’t work for me. Same result as in post #10. Tried with 2.66 GB + 5.32 GB and console shows OutOfMemoryException as in post #1 using old laptop, 32bit 1 GB RAM, W10, MP