What could cause a minimOSD to suddenly stop working?

I was trying to set my camera up to PWM trigger and I don’t know what I did but I broke something.

Before I did whatever I did, the minimOSD used to work. It would boot up and say “waiting for mavlink heartbeats”, and then it would display the telemetry data exactly where I told it to on the screen. The camera, OSD, and monitor were all set to NTSC. There was no flicker and everything fit on screen. It worked beautifully.

It stopped working. It’s blank. No error codes, no garbage data, just blank. Nothing looks different in OSD configurator. The USB port and FTDI still read from and write to it fine.

I changed the switches on the channels on my radio, so I could use one channel as a PWM camera trigger. I moved channel 8 from one switch to another, and then I noticed that in OSD Configurator, the default value for “OSD toggle channel” is Ch 8. So I thought that maybe I turned it off.

I set “OSD toggle channel” to “disabled” but the screen remained blank.I tried setting the OSD toggle channel back to 8 and flicked the switch but it didn’t turn back on. I set channel 8 to a dial and slowly turned the knob, so I could slowly scroll past every gradient of PWM signal, but that didn’t work either.

If I disconnect the plug on the FC side, it doesn’t transmit anything at all. It doesn’t pass video through when it isn’t powered. But when it’s plugged in exactly like it was before it broke, it passes video through. It just doesn’t display anything on the screen. There’s no OSD. All the lights on the board are still on. I checked the voltage output from the telemetry port on the FC where it plugs in to the OSD, and I saw 5v. It’s getting power. It doesn’t depend on a 12v source (see diagram), so there’s only one power connection.

What I’m trying to say is, “I think it isn’t bricked and the hardware still works.”

Did it stop trying to listen to the FC? Did I pull a wire loose? Did I inadvertently turn off the display? I don’t know how to turn it back on. I do not know what I did and I do not know how to fix it.

SR4_EXTRA1 = 5

This was working.


I plugged in a different minimOSD and it works now. This means mission planner is configured correctly. Also the hardware setup is working. So the problem must be in the OSD itself. What could have happened that would blank the OSD, even though it was set up correctly?

2nd Edit:

New OSD new problems.
The compass rose looks kind of weird.

And when it rolls the horizon gets weird too.

This is after I updated the charset.
What version of this configurator are we all using nowadays? Mine must be the wrong version.

Just for fun I updated the firmware and the charset . It works again now.
So if you’re reading this because you have the same problem, the solution is to plug in your FTDI chip and your usb cable and install arducam 2.2

And then I went back and updated the firmware and the charset on the one displaying the weird characters. That also fixed that one.

Update your firmware!