What board type is Pixfalcon

I’m setting up Pixfalcon I had in a drawer and the it wants a BRD_TYPE param to be set. What is the matching index for the Pixfalcon?

The wiki fails to mention this APM compatible board:


I checked with Tridge and the pixfalcon is apparently the same board type as a Pixhawk1.

OK. Perhaps the auto-detect thought it was another board. Might be a good idea to add the name to the wiki since there are a lot of them out there. I was pretty confused when rc2 worked and rc4 came up with the error.
Thanks for checking.

OK, here is the error:
check BRD_TYPE: no l3gd20 found

I can’t get this guy to work. I have another pixfalcon here running 3.4rc2 that does not have this parameter and it boots fine.

And I think my pixfalcon pilfered from 3DR may not be all that it seems…It may not be a standard issue, but a sample. Don’t raise any alarms for a bug just yet.

Did you ever figure this out? I am getting the exact same error. I can load px4 firmware OK, but can not load any arducopter firmware due to this error. I’ve tried lots of different versions of the arducopter firmware, and tried changing the brd_type, but nothing worked. I had been able to load arducopter firmware on this in the past.

@Jim_Forsythe have you tried Copter 3.5? It’s still in beta (so be careful) but it might better support this board.