Weird situation while building and flashing firmware

I am building ArduCopter-3.2.1 as described here
I was able to flash the HEX file with success, but the parameter list shows some extra flight modes that are not in the source folder, fetched from official git repo

Source code file - defines.h

Actual parameters list


copter 3.2.1 is very old…
The issue you see is that parameters documentation isn’t embedded inside the firmware, so GCS are getting it from our server that only giver the lastest parameters documentation. That is why you see lastest parameter documentation when using a 3.2.1 version.

Do you mean that they are not actually there?
I have tried to add my own mode, but it didn’t showed there. I only want to activate this mode with CH5, it’s OK if it’s not in paramteres list. Can you guide me?

Also, thank you.

It is not programming but archeology. It is highly recommended to switch to recent code. There are better cheap flight controllers with far more sophisticated processor than the AtMega2560…

My options are NAVIO2, Pixhawk or APM 2.x. (It’s for a competition). Since Pixhawk’s are twice as expensive as APM’s, I cannot afford them.

FYI, I solved the problem by modifying parameters file of GCS. Without this modification it’d still be available through handling suitable FLT_MODE slot of parameters.

In a competition where these are the options, APM starts with an irrecuperabile handicap…