Weird results after saving AutoTune PIDs


I’m having some issues with AutoTune.

Before running AutoTune my hexa flies fairly well, no visible issues.

I’m able to complete AutoTune. Before I land, it flies really smooth with new PIDs (AutoTune switch always on).

My problem starts when I land and disarm with AutoTune turned on. After that, the hexa becomes very unstable, shaking, jumping, the motors seems to be fighting each other.

Tried twice with same results. Vibrations seems to be between the limits. Attached the new PIDs generated by AutoTune.

Bin log download (4Mb)

Any advice is welcome.

Hardware setup:
Frame: Tarot 680PRO
Motors: Turnigy Multistar 4108-380KV
ESC: HobbyWing X-Rotor 40A
Props: 1355 CF
APM: 3.2.1 (latest)

we missed the most important part of the logs where you fly with autotune params

It’s fun to watch though, gotta give it that!

My autotune does the same thing, flies perfectly after completion and then sucks after committing the changes.

Gotta drag the laptop out and refresh the params before you land and look for a difference in values saved. I’m not 100% positive the wrong values are being saved. If it flies good after autotune while the switch is still high then maybe it is something with saving the parameters correctly.

Going to do this next weekend and collect proper logs. But this seems to be an issue with 3.2, some people are discussing this problem in other threads/forums as well

What I’ll do

  • Fresh 3.2 install (no upgrade from 3.1.x)
  • Run autotune, save PIDs while flying (thanks Bluetooth)
  • Land, save, see if the problem persists

Some people are saying it may be related to some parameters kept in the upgrade process that are mandatory to 3.2 (like the Throttle PIDs)

  • If it fails, will install a fresh 3.1.5 and try again to see what parameters it generates.

At least I’m not alone on this boat and it don’t seems to be related to my setup/hardware :slight_smile:

We had the same last week…
thought the compass is not tuned… :open_mouth:

I think we found a solution… nothing else helped…

  • Checked the acc. vibration, Added some damping.
  • Tried calibrations…
  • Flashed the firmware again…
    nothing made any change, still erratic movements specially on throttle. :frowning:

[color=#FF0040]Downgrading the firmware to 3.1.5[/color] made the difference … suddenly all spastic movement stopped… :smiley:

I’m having the same issue. With the new pid I get from autotune, it’s pretty twitchy. When flying auto missions for mapping, the motors sound really weird, like it’s fighting itself the entire flight.

Looking your values PID see the Roll and Pitch rate is 0.2850 and 0.3500. Why APM software in my QUADX APM2.5 only allows me to raise Roll and Pitch Rate until 0.200?


Has a solution to this been discovered for 3.2 firmware?

I can confirm I am still having the same problem as described below:

Take off prior to auto tune and the multirotor flies but not well.
Auto tune completes and it is flying amazing.
Land and disarm with the autotune switch still high.
As soon as I begin a new flight with the saved auto tune parameters it is not flying anywhere near as well as it was just prior to the disarming. (Twitchy and spas tastic)

I can confirm via my telemetry link that the auto tune parameters saved appropriately.
When i did an auto analysis of the auto tune flight The log file reported autotune - good.
I can also confirm auto tune sets PID settings that are way above limits. For example, Pitch and roll Stab 18 (limit 12) Pitch and roll KP 0.35 and higher at times while limit is lower. Does anybody know the effect of setting values above the limit? are the above limit values ignored when saved resulting in weird flight performances post auto tune?

Also can anybody confirm this problem persists in 3.3? I don’t like the idea of downgrading because it is the mental opposite of progress.

I can report that autotune in 3.3rc5 is working great. As long as you don’t run into the EKF errors.

guys, Do you have any more solution? I’m waiting for it :frowning:

The same problem here - help neeeeeeeeded!!!

The whole aggressive thing on takeoff only happens in stab mode. Just an observation. Alt, auto or loiter don’t exhibit this behavior.

I solved this problem at 3.3.3

I changr the Autotune AGGR from 1.0 to 0.5