Weird Flight mode behaviour with H-Frame quadcopter

Recently, I changed my quadcopter frame from X-frame to H-frame. Reversed all the propeller directions as stated in the manual. Everything is perfect, hovers perfectly. But the APM always remains in Simple mode although I unchecked all Simple and Super Simple boxes from all the flight mode options and all are just set to stabilize mode. But the quad always follows a global direction. This might sound very weird but if anyone has had this problem please help.

Logs? That would help.

@BigTulsa Can you please tell me how to get the logs.

I was out for some days. But now back to debugging. Its still not working. Thanks

@BigTulsa 2017-02-02 23-20-44 1.bin (92.8 KB)
2017-02-02 23-20-44 1.bin.log (180.6 KB)

These are the logs I got through MavLink. Can you please help. Thanks

PROBLEM SOLVED. Got the solution from here
Last time I set Ch8 toggle to Super Simple mode. But when I changed it back to do nothing it didn’t get written properly.
Changed it from the FULL PARAMETER LIST and now its working.