Servers by jDrones

Weird drone crash analysis

This quadcopter crashed and I cant seem to find the reason for it. I’m wondering if anyone can help with this.
https://drive.google.com/open?id=1or81QYc-6f5mL9J7Zq-JcTizIpKzFJ4I

Please provide a detailed account of what happened. It makes log analysis a hundred times easier.

1 Like

Okay will get that for you. I have been staring at this log for a while but according to the person flying the drone went up a couple hundred feet went out 40yards then crashed. But this log files map shows they had a mission that went quite a ways out then put it in rtl mode but the drone didn’t quite make it back. ive looked at curtot and it shows it used 2800mah out of a full 5200mah lihv battery and the lowest voltage it got to was 14.5ish.

I was looking at the wrong map I think but flying for 13 minutes seems like the drone did have some time to get out farther than 40 yards.

This looks like a good flight to me. The drone tipped over when it landed, but everything else is normal, including the descent to landing at the home point. The motors were still running when it fell over, so the pilot probably observed it thrashing the props around on the ground and then the auto crash disarm kicking in.

The only thing of note besides that is a brief transmitter signal loss. This might be what prompted the pilot to RTL (RTL was not triggered by TX failsafe).

Okay thank you rick, I think what might have happened was that the log file I was sent was the flight before the crash. I think what’s going on is a failing pixhawk 2 this was the 3rd crash on this quad. First time it looked like an eagle was flying by and we thought it attacked it, second time the battery monitor seemed to have been reset and not calibrated even though the failsafe was set to rtl at 14v. This third time i was sent log files for flight 18 and 19, and 18 was the one i posted up but 19 is 3kb and seems to have no data whatsoever. I wonder what would cause the drone to not write a log after it had rose 400ft and then traveled 40yards and then come down crashing. Pixhawk 2 issue maybe?

Here is flight 19 that i was talking about.
https://drive.google.com/open?id=1oOnEayNTaPpzIfshSTJEgfDSEo9m8dK5

Hm. Was there a GCS connected to the drone on that flight? If so, you might be able to get a telemetry log, at least.

Do you know anything else about this flight? For example, you say it flew up at first - was this a controlled flight, or did the drone just fly away on its own after arming? And when it came down, did it just turn off its motors and freefall?

If the ascent was a controlled flight, then I can only guess that the log was corrupted or truncated due to the crash, although I’ve never seen a log this short. If it was an uncontrolled flyaway, then maybe the flight controller failed or lost power after arming somehow, causing the log to not be written, but I am not sure if it is possible for PWMs to be sent to the ESCs if that happens. If so, that might also explain a freefall crash, as the Pixhawk would reboot in flight and cut motor outputs.

I will let you know tomorrow I will have the drone and pilot with me then. Thanks for the help.

So just finished talking with the pilot and the drone was setup to run a 700 acre field with the mission being segmented into 7 portions. He started the mission into automode and the drone flew up 300ft roughly then flew out about 30 yards tipped over and fell. He had started a previous mission (18)successfully but the drone was getting out of sight so he put it in rtl and it came back then tipped over when it landed. Earlier that week he did have an issue where the pixhawk2 base would produce a strange tone and wouldn’t boot up but the gps lights wouldn’t go red only the base of the cube would turn orange and removing and reinserting the sd card solved that issue. Could this have been caused by a faulty sd card? I’m not sure if it would’ve been caused by power issues because it has 5v ran to the servo rail and the Power cable 1 connected to it. This copter is also running 3.5.5. having the drone connected In the messages I am seeing -need 3d fix (indoors)-throttle below failsafe -and there is check board voltage after longer intervals of time. And after plugging in the battery gyros inconsistent.

The check board voltage error was due to the power module voltage reading shifting up .4 volts after the crash making 17.4 volts read like 17.8… maybe failing power module could have been the issue? Strange thing is with usb power its reading that its drawing 1 amp at .06v and with usb power its asking to check board voltage again.

Disconnected the 5v input from the pdb to the servo rail and the and it now seems to be normal and drawing .2 amps over usb

The failed to boot and SD card issue sounds suspicious. Have the pilot check this link and see if any of those sounds were the one he heard.

Regarding the board voltage, it would be informative to turn on disarmed logging (LOG_DISARMED = 1) and power the drone without USB and leave it for a while until the board voltage message appears. Then we will be able to see what the problem is with the power.

Now i’m pretty sure after so many crashes the carrier board is toast. Removed the gps from on top the cube that was double sided taped in place and now it wont power up with the battery, haven’t tried usb power but I fear causing unnecessary shorts internally. The noise was none of those in the link you posted. Here is the sound https://drive.google.com/open?id=1ktbRf1dy5frwzYOetaY_KQ9UhBtzISGq

Pixhawk 2 only powers on via usb power now, but it still receives current information from power supply. Here is a log of the cube sitting there with usb power then I lift it and plug the power1 cable in and it starts reading the voltage. Then a little later I disconnect usb and the pixhawk turns off22 12-31-1999 5-09-32 PM.bin (432 KB)

a picture of the carrier board, it appears to be slightly bent.

Took me a bit, but I found that tone pattern in the Ardupilot code. As far as I can tell, it means that the SD card was not detected during boot. The bend in the board is definitely worrying.

Have you tried powering it with a different power module? According to the log, there is no power source connected other than the USB (POWR.Flags = 4). Not even servo rail power. The power flags are defined as follows (multiple statuses are added together):

MAV_POWER_STATUS_BRICK_VALID=1, /* main brick power supply valid | /
MAV_POWER_STATUS_SERVO_VALID=2, / main servo power supply valid for FMU | /
MAV_POWER_STATUS_USB_CONNECTED=4, / USB power is connected | /
MAV_POWER_STATUS_PERIPH_OVERCURRENT=8, / peripheral supply is in over-current state | /
MAV_POWER_STATUS_PERIPH_HIPOWER_OVERCURRENT=16, / hi-power peripheral supply is in over-current state | /
MAV_POWER_STATUS_CHANGED=32, / Power status has changed since boot | /

If you’re sure that your power module is okay, then you can inspect the power selection board if you’re adept at such things. It’s located on the underside of the main board and it looks like this:

I did try a different power module. I even tried pluging it to the power 2 port and also tried powering through both power ports with 2 power modules. Looks like we are going to return it to hex to see if they can figure out the issue. So far I think the crash was related to a cube issue and the new power issued maybe due to the bend in the carrier board caused by the crash. Thanks for your help rick I appreciate it.

Servers by jDrones