Servers by jDrones

Weird behavior in tracked vehicle when STEER_TYPE=1

Hi to all members, and BIG thanks to the dev team for making v4.0 possible.
I have just installed this new version in one of my pixhawks and mounted it in a tracked vehicle (tank) a mini T100 frame, with some changes for adapting 2 motors made out of 996 modified servos, although the size is not relevant for my question.
The fact is that, configuring the vehicle as PILOT_STEER_TYPE 1 as I supposed it needs to be (tank=skidsteer), leads to weird behaviour in radio response, both Radiolink and Taranis. Simply ungovernable.
But luckily for me leaving the parameter PILOT_STEER_TYPE 0, the manual response is as desirable, that is, Pixhawk is mixing channels for dual tracks fine, as a tanks is supposed to go, both tracks paired front-rear, inverted to steer.
Of course Servo1_Function=73 and Servo3_Function=74 with pins to pixhaw rail positions 1 and 3 respectively.
No mixing in radio, with a fresh new model in memory, and RCMAP in MP changed to 3-1-2-4 (pitch-roll-th-yaw) as stated in wiki.

¿Is something wrong with PILOT_STEER_1 and/or why it is not working as supposed to be for tracked vehicles? ¿Will it work in Guided or Auto, even when it is a tracked vehicle and Manual is working fine only when PILOT_STEER=0?
:slight_smile:

PS: I’m using sikradio so I can modify performance directly. When changing RCMAP_, the tips in MissionPlanner states that needs to be rebooted to take effect, but Pix is accepting changes fine without rebooting. I suppose it is something from old APM code. Just saying, in case you want to change this tips from compilation.

Best regards.

PILOT_STEER_TYPE 1 is used for two stick/paddle input, like in full size skid steer vehicles. For a standard radio TX, where you control the movement with one stick PILOT_STEER_TYPE 0 is fine.

Thanks for your input, but the radio also has two sticks and this ain’t no working. That is, you can’t use the two sticks on the radio (one for each motor/track), and must only use only one, disabling the option to STEER_TYPE=0

Weirdest thing is that independent control for each motor/track in theory doesn´t need mixing, and could be easily achieved vía standard assignation to channels, even on the potentiometers or bottomsliders -depending on the radio model-.
I will test it with gps in guided as soon as I can.
But manual control is not a problem as it could be achieved in multiple ways, my concern is Guided mode.
Best regards :slight_smile:

@DIOSITO,

Looks like you’re making good progress. If set PILOT_STEER_TYPE = 1 and then try to control the vehicle, then download a log and post it here then we can have a look. It’s a guess but I suspect that the RCx_TRIM values are incorrect (they should normally be about 1500) and/or one of the channels is reversed.

1 Like

This is the “out of the box” configuration with this custom-made motors. I tested several times with freshly installed firmware and new model data in the radio, so I assume the problem is in the hardware-level (I’m using the potentiometers of the servos as ESCs). When setting PILOT_STEER_TYPE=1 the forward function (both tracks advance) is automatically set to both sticks full Top-Left. Reversing a channel doesn’t center it, just translates movement to another corner.
Reverse (both tracks rear) doesn’t appear to work. Obviously turning is broken in the same way because FORWARD is totally messed up.
PILOT_STEER_TYPE=0 works out of the box, but without reverse.
I repeat I dont have any problem with tuning Manual, because I can achieve this for other ways. My concern is ¿Will GUIDED/AUTO work? I suppose yes.

I’m the only one experiencing this behaviour so I assume that the problem is because I’m the only one trying to use servo electronics as motors, instead of using a dedicated controller. LOL, I just wanted a very slow vehicle thats why I’m trying to use servos as motors.
I just wanted to use forward-reverse-turn, so I give up with STEER_TYPE=1, stick to STEER_TYPE=0 and try to made an usable vehicle (yes, insanely slow vehicle lol) so I trimmed the servos.
RCX_ going in the range from 500 to 2000 with trim in 1200 is the only way I have found to make reverse usable using these modified servos as motors. I dont know why reverse is not working out-of-the box, but I found tweaking the limits and the trim of the servo-controller-as-ESC is working just fine in Manual. I will upload some pics this weekend.

I will wait for rain and snow to dissapear, then try GUIDED modes with this one little shit. And I have a pair of dedicated controllers with 330rpm DC motors, I will give them a try with another Pix and one ultrasonic sensor I have here to test.

Best Regards.

@DIOSITO,

You can also try acro mode to see how that works. At least if the EKF has a good position estimate (the EKF label on MP’s HUD should be white, not red or yellow) then Acro mode will use the same speed controller as Auto will.

SOLVED: I have found that the integrated controller in the servomotors is not “factory trimmed” (they are modified) at the middle, they have an offset of around 33% to one side. This was causing unexpected response.
Thanks to all.

1 Like
Servers by jDrones