Waypoint 0 ? osX APM planner


Im curious. I thought way point 0 would the the Battery Power up position, same as RTL default position?

However Im finding that waypoint 0 defaults to my previous waypoint 0 from an earlier mission.
So when I try to clear all the waypoints, waypoint 0 remains the same as old position.

This was a problem when I was in a different field…and could definately explain my flyaway on RTL one time.

Is it a bug , as I cant actually delete waypoint 0 or reset it? I seem to have to manually drag it to theright place? This is on osX APM planner last few releases



Waypoint 0 is the home position. It’s set in APM:Copter when you first ARM (or if you have taken off in stablize, the instant you get a GPS lock) (I’m not sure the behaviour in Plane)

I’ve noticed this same behavior recently with my APM plane. No matter how many times I reboot and re-write the mission, Waypoint 0 still pops up as my last home position.

I’m using the arming sequence as well, so I would assume the home would reset to the armed location, but it doesn’t appear to be.

Thjat is what I thought.

In which case there is currently a bug.
I have the latest OSx APM Planner.

The Waypoint0 is not updating on power on. There is definitely GPS working as the map is centered correctly on my UAV but waypoint0 is across town at the previous field I had flown in last time.

If it is a bug its huge one, as this is what I think cause my random flyaway on RTL.
Everything was going well it did the mission so GPS must have been fine, then I switched to RTL and it flew away in a obvious direction. If Waypoint0 is the RTL location then that makes sense.

I tried multiple power off on, and the planner based reinitialise action.
I’ll get a screen shot next time I try

Hope this is useful info. It looks liek the above poster also has similar.



Hi Bill

Have you managed to check this one?
To see if waypoint 0 is behaving the way you expect it.

I flew my iris again on the weekend and I had to drag the waypoint 0 across the map to my new location. It wouldnt auto update.

One thing to note at one stage I disabled the gps preflight check (as my HDOP was 3 and it wouldnt arm) could that do it? Even tho my location had good GPS and was accurate, and I ran the preflight checks maybe this setting was stopping it?



If you arm and then redownload the mission it will update. AC only updates home on arming.

Maybe I can work out a feature that on detection of ARMing AP2 will initiate a call to get the new WP0 location.


If this is the case. Consider a new user to something liek an iris.

Go out to fields, power up and fly.
Maybe setup a mission

Next day goto another field to do simple fly test. No APM planner involved

At this point where do you expect the home WP0 to be.

My APM planner sometimes say reconnected aafter 123423234563456 (or 1e3) sec which means it still thinks its on a mission? Its probably a setting I have to always reconnect as if it is part of the same plan.

One way around could be i nthe actions tab. There is already a preflight reboot. Maybe just add preflight set home.This would be handy as sometimes I power up before walking out and findign good launch point. Usually I have to unplug then replug which is a pain on the iris with its battery door. If I could run ereboot and set home that would be great!!


That message is the time delay between receiving a heartbeat (ie. i’m alive) message. It’s not related to mission status, i.e. Auto mode.

As i said, I’ll add a feature to request the home position (ie. Waypoint 0) on arming to a future release of AP2

I think AC3.2 adds the ability to use DO_SET_HOME command, so addingt hat feature seems like a good idea as well. In the meantime HOME is always set to the position when you ARM ArduCopter. It’s not controlled by the AP2



I never used waypoints or AUTO mode on my 3DR Iris yet, but I have used RTL a lot. I have had one time where I did not arm after GPS LOCK (GREEN), and so when I did RTL it flew over my house (and panic ensued!!!) fortunately I caught it quick enough and got it back to where I was and on the ground. Sometimes it takes a long time for GPS LOCK GREEN, so get used to WAITING for it or else DO NOT use RTL/AUTO modes.