Servers by jDrones

Way too big bounce back with pitch


(Hans) #1

Hi!
I’m having trouble with PID loop. Everything worked good when I used these same params with quadplane setup. Frame is same, weight is also the same. Now as copter, the aircraft is very agressive, even though thr expo is 0,25. Today I did the first test with copter 3.5.7, hardly touched the pitch and it just started to bounce. Any idea where to look at? is it P, I or D term that makes all this trouble? Or any other maybe?
weight ~6kg
scorpion m4215 320KV motors with 15’’ props
phoenix edge HV lite ESC-s
pixhawk 2 with heree+ compass
8s 10000mah battery

Due to the fact that aircraft is little bit overpowered, I limited max motor PWM to 1700, expo to 0.25


also here is the binary log file:
2018-11-09 14-03-12.bin (300 KB)

Thanks


(Mike Boland) #2

I think your assumption about it being overpowered is correct.
If you have a look at the RCout it is shutting motors 1 & 2 down trying to maintain stability.


Limiting the max power is not going to help in this case as it never gets there.
And you also limit the range over which the controller can stabilise the craft.
I would try adding more weight, maybe another battery or dummy payload.
Get the PWM close to 1500 out and do an autotune.
Consider updating to copter 3.6.


(Hans) #3

Thanks Mike for the analysis. I’ll add 1-2kg and try again.
Does the 3.6 update have any advantages with stability ?


(Mike Boland) #4

The new loiter code is quite an improvement.
There are other numerous fixes.
So yes, it is a worthwhile upgrade.


(Luka Jurjevic) #5

Hi mboland,
Could you please further explain this statement? Why would autopilot stop the motor to maintain the stability?

Do you think this could be the issue here too?
Here are the screenshots of the log RCOUT and ATT pitch:


Copter specs - OctaQuad x8

Motors - 8 x T-motor Antigravity MN4006 KV380.
Electronic Speed Controller (ESC) – T-Motor ESC 40A.
Propelers - T-Motor Carbon Props 16/5,4’’. (4 x cw, 4 x ccw).
Batteries – tattu 6 CELSS, 22.2V, 355.2Wh, 16000mAh
The weight during the flight - 3,5kg (copter) + 4 kg (batteries) = 7,5kg

Thanks!


(Mike Boland) #6

Yes, same problem.
You can see from the Desired to actual in the first graph that it is over controlled by the PIDs and is ‘ringing’ or oscillating. This eventually increases until it is out of control.

In the second you can see the motors working harder and harder, in turn, trying to level the craft.
Towards the end you see that oscillations have grown to the point where shutting down the motor isn’t even enough to bring it level.

You need to adjust the PIDs manually to get it flying safely to the point where you can do an autotune.
Have a look here http://ardupilot.org/copter/docs/autotune.html?highlight=autotune
Have you adjusted the RATE_RLL_FILT_HZ and RATE_PIT_FILT_HZ as recommend?


(Luka Jurjevic) #7

Thank you very much for the reply Mike!

It is still a bit unclear to me… Do you say that the copter is overpovered in terms of the lift that motors produce in comarison to its weight, or simply that PID parameters are ‘overpowered’ in comparison to the copter weight?

I’m just trying to figure out how to make this never happen again. With tuning the PID parameters or adding some weight to the copter, or any of it would solve the problem. Another question is is autotune better than manual PID tuning? Our PID parameters are manually tuned, however we did not tune it but the copter anufacturer tuned them.

RATE_RLL_FILT_HZ and RATE_PIT_FILT_HZ (ATC_RAT_RLL_FILT and ATC_RAT_PIT_FILT) are set to 20Hz, contrary to the 10Hz that are recommended in the Autotune WIKI. But what exactly does that parameter change?

I did open the separate topic before to analyse the our crash cause - Crash cause analysis I would appreciate if you give a look at the ATT data after the crash and fixing the drone, and commend on the PID controler graph!

Best regards,
Luka