VTX smartAudio Setting

Need help Again. :frowning:

This time is about the setting of vtx. The vtx I use is the ovx303 of happymodel(Happymodel OVX300 OVX303 5.8G 40ch 300mw VTX OpenVTX – Happymodel)
, which supports SmartAudio. I connect it to T2 pin. According to the document, the configuration is as follows:

serial2_protocol = 37, serial2_baud = 4, serial2_options = 68

VTX_Enable = 1, VTX_BAND = 0, VTX_CHANNEL = 0, VTX_MAX_POWER = 400, VTX_POWER = 400, VTX_OPTIONS = 0

However, the ovx303 did not start transmitting signals

I changed the firmware to BF, After setting the parameters, the ovx303 can work normally. It proves that there should be no wiring problem in the hardware

Did I miss any settings?

param is here: HlybroHakuteF7_mini_v2_param_211108_1447.param (19.2 KB)

Thanks !!!

VTX_OPTIONS = 0 sets the VTX to pitmode. How close are you to the VTX when trying to detect a signal?

https://ardupilot.org/plane/docs/parameters.html?highlight=vtx#vtx-options-video-transmitter-options

You probably want VTX_OPTIONS = 1 to keep the VTX at low power until arm, or VTX_OPTIONS = 3 to unlock the VTX if you want to operate at max power.

I tried both 1 & 3, not working… the receiver is very close, 10cm.
Maybe the serial port is set incorrectly. I’ll try another VTX module… Maybe there is a compatibility problem with ovx303… thanks anyway.

Not sure where you got this from - it should be 4

from here: Video Transmitter Support — Copter documentation

both 4 and 68, not working…

It’s likely a compatibility problem then

Yes, today, I trid the RushTank VTX, it’s working fine. using the same settings.

The OVX303 is base on the OpenVTX project, Maybe there is a compatibility problem.

I need find a new small size VTX…

Thanks verybody !!!

1 Like

With below setting VTX power remains 25mW even after arming and raising from configured channel.

TX_ENABLE=1 //to enable video transmitter support.
VTX_BAND=4 //RaceBand
VTX_CHANNEL=1

RC11_OPTION=94 // Control VTX Power from Channel 11
VTX_POWER=25 //default vtx power after arm
VTX_MAX_POWER=800 // Rush Tank Ultimate Plus 5.8GHz VTX w/ Smart Audio supports
VTX_OPTIONS=1 // Pitmode until armed

SERIAL6_PROTOCOL=37 // Smart Audio
SERIAL6_OPTIONS=4 //Enable half-duplex which SmartAudio requires
SERIAL6_BAUD= 4 // 4800 -SmartAudio baud rate

1 Like

Hi all,
Been tinkering with the vtx control,
Seems to working nicely.
I am using an AKK fx2 ultimate that has a max power of 1200mW, but the vtx_max_power param only goes to 1000…
How can i utilize the full vtx power in that case?
Thank you.

Did you try just setting it to 1200? I think you will be able to do this although whether it has the desired effect I am not sure

Thank you Andy.
Ill try that.

Hi,

I have been testing the VTX functionality for the first time and (nearly) everything is working but I have questions which i have not been able to find answers for yet. These are:

  • My VTX is an Eachine Tx805 which can transmit 25, 200, 600 and 800 mW. The Arducopter messages however display 25, 200, 500, 800. Is there a table somewhere which can be changed so correct values are shown? With all possible alternative VTX’s it seems like a table in the settings could solve the problem.

The VTX_OPTIOS param is a mystery. There are some auto changes I think is a bit confusing and these are:

  • Setting the RC channel to lowest value always auto changes the VTX_OPTIONS to 1 (plus any existing setting), i e enables pit mode. This is mentioned is the docs so that is a “feature” but was a bit confusing anyhow to begin with. My preference would be to skip this auto change and let me set the option to 1 if I wanted to have it but this is no problem.

  • VTX_OPTION set to 2 have no effect whatsoever. If I start up the copter and power is set to for example 200 before shutdown this is what I get. Even though copter is not armed there is no pit mode. So pit mode until armed seems to fail or am I misunderstanding?

  • Pit mode until armed and pit mode when disarmed seems to me to be overlapping functionality (before arming the copter is disarmed, right?) Maybe another misinterpretation on my side.

  • VTX_OPTION set to 4 is auto changed to 5 after a restart. As the copter is disarmed after a restart this seems to be unneeded but is of course not an error, just confusing that parameters are auto changed.

I am running the latest stable version of Arducopter on an Lumeniere Lux.

I’d be very grateful for any input but, as earlier mentioned, everything is working with the exception of pit mode until armed.

Many Thanks for any info!

My VTX is an Eachine Tx805 which can transmit 25, 200, 600 and 800 mW. The Arducopter messages however display 25, 200, 500, 800. Is there a table somewhere which can be changed so correct values are shown? With all possible alternative VTX’s it seems like a table in the settings could solve the problem.

I have a PR pending to fix some of these power management issues. I was waiting for TBS to fix CRSF but it does not look like its going to happen any time soon so I might see if I can progress this now: SmartAudio/CRSF power management by andyp1per · Pull Request #19497 · ArduPilot/ardupilot · GitHub

The VTX_OPTIOS param is a mystery. There are some auto changes I think is a bit confusing and these are:

Setting the RC channel to lowest value always auto changes the VTX_OPTIONS to 1 (plus any existing setting), i e enables pit mode. This is mentioned is the docs so that is a “feature” but was a bit confusing anyhow to begin with. My preference would be to skip this auto change and let me set the option to 1 if I wanted to have it but this is no problem.

I can see why its confusing. The feature currently works by looking at that bit because its really simple. To not use it would make the code quite a lot more complex. Certainly doable, but I’ll have to have a think

VTX_OPTION set to 2 have no effect whatsoever. If I start up the copter and power is set to for example 200 before shutdown this is what I get. Even though copter is not armed there is no pit mode. So pit mode until armed seems to fail or am I misunderstanding?

Sounds like a bug. Might be fixed in the PR above

Pit mode until armed and pit mode when disarmed seems to me to be overlapping functionality (before arming the copter is disarmed, right?) Maybe another misinterpretation on my side.

Its the difference between disarming a crashing. Some pilots never want pitmode to engage once they have armed so that they can see where they are if they crash

VTX_OPTION set to 4 is auto changed to 5 after a restart. As the copter is disarmed after a restart this seems to be unneeded but is of course not an error, just confusing that parameters are auto changed.

Its a bit mask (5 == 4 + 1), so the change is to pitmode - which is the same as you are seeing above

Hi Andy,

Many thanks for taking the time to respond, your support is so valuable to all. (I have also followed your excellent walk through and videos for the 7" LR build and learned a lot which I hardly could have learned by myself. I did build one based on the hw specs with the exception of the TX805 mentioned above as well as ELRS for the radio, both of which I already had. Also the frame is of my own design and 3D-printed. My version of the 7" LR became a great flyer for my purpose which is photography).

I forgot to mention a couple of observations:

  • Working on the connected copter and VTX power is set to any value (say 200) and without pitmode. Setting the VTX_OPTION to 1 and save the parameter will immediately swith to pitmode as expected. If I then for some reason reboot the copter the vtx_option is auto changed to 0 and pitmode is no longer active after reboot. This is no major problem but in a situation with several copters around it may be desirable that the pitmode setting survive a reboot.

  • In the docs (Video Transmitter Support — Copter documentation) there is a sentence I find confusing: “For example if max power is 200-499mW, switch positions 0 results in 0mw (pit mode), 1 and 2 result in 25mw, 3 and 4 result in 100mw, and 5 results in 200mw.” The -499mW might be a typo or am I misunderstanding something?

Thanks again and I am looking forward to test the changes from the PR.

I have been testing a Rushtank ultimate plus and it does not work, even in betaflight. Going to have to give up. I suppose I could have a bad unit.