Vtx control, max power question

Hello, I’m using vtx control but still has one question.

There’s a 3 pos switch configured to have 3 power levels

  1. 25 mW. Working nice
  2. 800 mW. Working nice
  3. Max power. Isn’t working nice. It switches to 1586 mW as expected, but in 1 sec it switches to 800 mW as not expected.

Can I do something to have not switching automatically frim 1600 to 800 mW?

My vtx is 1600 mW possible and I want to use this power level.


Is this a TBS Unifi Pro32? I’ve been having this exact issue using a TBS Unify Pro32 with SmartAudio and I haven’t quite figured out what’s causing it yet.

Did you limit the minimum value from the 3 position switch to prevent the first position switching off the VTX?


Well… I have rush tank solo.
I’d adjusted minimum and middle values of the switch to have what I need.
But have a problem with maximum value.

Maybe, someone can recommend how to fix.


Try removing the settings on the switch and power up the plane with the switch in the minimum position.

I think there might possibly be a bug in the smartaudio code where the channel must be at minimum on startup in order to switch to full power.

it could be the thermal protection if your running at full power with no airflow.

No, it had open design and located directly into airflow…
Also, surrounding temperature is not too high now :slight_smile:

What vtx?
Is it eachine tx805s vtx?
I use these and can’t get the power level to work either .
I turn it on and it’s always stuck at 500mw(green light) .

I’m using rush tank solo.
It can transmit at 1600 in maximum.