VTOL Unstable & crashed in Qstablized mode

Hi dear all,

I’m writing here after struggling to fix the issue for several weeks now.
We have a 7kg VTOL , trying to do the maiden. But still no luck so far.
It was giving EKF_YAW_RESET error every time i increased the throttle in Qstablized mode. So as I have seen in some threads I put the external GPS away from any power sources.
Using CUAV NEO 3 PRO GPS with compass. I think its using RM3100 compass.

However after doing that i get very good compass values but still giving EKF YAW RESET message. I kind of can’t figure this out. First i tried with EKF3 and then also EKF2. same thing happened

Also when I check desired pitch and actual pitch. It has unwanted movement.

I cannot lift the VTOL from the ground at all. It seems like right at it’s trying to take off. Autopilot is giving erratic commands . Almost crashed multiple times.

I’m scared to do anything more utill i figure this out.

I’m using pixhawk cube orange. With Mauch power module.
Also pleae check in the log file. Power is going down to 4.8v as i increase the throttle. Is this normal?

Please give me some input. Id really appreciate.

Please find the bin file here. ( This is after i totally disabled the internal compass and put the external compass far away from any electronics. Actually had put it on a mast)
And then calibrated the compass as advised in the wiki


If you want a video of the flight i tried I can send that also. You can see how the aircraft is struggling

P.s - i have double and triple checked the motor order and Propeller directions.

Thank you very much in advance

any ideas Anyone? :frowning: