VTOL Strange behaviour after firmware updated to 4.3.2

HI ALL
My VTOLwas working well before updating the firmware to 4.3.2
When testing in automission is acting in strange way as it shown in photo


I would appreciate any advice for that issue.
Best Regards

here my log file for any purpose
i’m using mfe fighter vtol 4+1
https://drive.google.com/file/d/1u1uJCQwQteaCwelZCm9Ew_u7HlpSmYQt/view?usp=share_link

hi ı have a kind of same issue, ı am in a 4.2.3 fw, but my plane is 4 meter wingspan, did you solve that problem

The log file is locked.

sorry for that, file unlocked.

unfortunately not yet !

All the pitch and roll tuning parameters for fixedwing mode are still at default. The plane needs to be tuned.

https://ardupilot.org/plane/docs/tuning-quickstart.html#tuning-quickstart

Thanks a lot , i’ll do that then reply again
also until now i’m not using airspeed while i have tow installed because of previous problem in transission phase. to prevent such behavior is it mandatory to activate them ?
Best Regards

Can you clarify this? Do you mean two installed?

I can’t speak to how AP handles transitions without airspeed, however in fixed-wing mode AP will fly very well without airspeed but it will fly better with an airspeed sensor. So it’s your call.

Thanks Allister for your replay.
For airspeed , yes i mean tow installed but deactivated du to airspeed failure one day when the drone attempt to do transition from vtol to fixed-wing.
since that day i disabled it and the drone fly very well. I tested in 18KM range, 500m altitude and flaying for 1hour with only 48% of the battery capacity and everything was great before updating firmware to 4.3.2. And even now every think is well except the attitude of the VTOL when reaching a WP.
That behavior was smooth before updating firmware even without tuning roll and pitch like you mentioned as it shown in this photo.


but now it become like this after updating the firmware.

Best Regards

The flight path has nothing to do with the update, but with WP_RADIUS set to 2 meters. Therefore, the aircraft overshoots each waypoint by far instead of turning in time to the next one.

Rolf

Thanks Rolf ,
that make sense now. i’ll adjust wp_radius to a reasonable value and try again.
Best Regards