Vtol oscillate in pitch while back transition

Hello friends,
I am working on a VTOL and I have done auto mission with the VTOL. Currently, I am facing two problems the first one is;
I set the default altitude to 40 m in the auto mission but when the transition happens it first go to 50m and then it comes back to around 40 m in the whole mission.

and the second one is that:
when it comes to the back transition all four motors come back to power but during this, the VTOL oscillates up and down in its pitch axis. I have also increased the D gain for pitch axis of Quad motors but I get the same result. I have manually tuned the quad motors (By increasing P and D values in pitch and roll axis and I am satisfied with its performance, you can check the roll and des roll and pitch in the log) but I haven’t done autotune neither in quad mode nor in fixed-wing mode.
I have attached the bin file for your reference
Thanks in Advance
@Eosbandi
@Liquidforce

Log File: https://drive.google.com/file/d/1oGM85yM8bVLVNLMIKSwmoHUJ5uF1mYDs/view?usp=sharing

@GregCovey pls have a look at this.

Hi akhil,

Your Goggle drive requires access, and although I requested it, I received no e-mail granting access.

It looks like you resolved your issue so what exactly are you asking for?

Cheers!

Hi Greg,
I have given you the access.
pls look at this
@GregCovey

akhil,

I looked at your mission plan using both Mission Planner v1.3.74 and QGC v4.1.1. Neither GCS was happy with your first line in the plane…presumably used for take-off. This could explain your initial height going over 40 meters until the next waypoint is invoked.

When transitioning the VTOL to land, you use a VTOL_LAND command which may try to abruptly stop the vehicle over the home position (like switching from FBWA to QLOITER mode). I would recommend using QRTL to allow the vehicle to transition before reaching the home position.

What GCS were you using to create the mission?

Cheers!

@GregCovey
Thanks for your reply.
but I have also tried the RTL (Mode 1) (in which VTOL comes back to home in fixed mode and the convert into a QRTL when it comes under the RTL_RADIUS) I have seen the same behavior in the pitch axis.
I am using Mission Planner 1.3.74 build 1.3.7563.27684 for planning the mission and I am using VTOL_TAKEOFF for Auto take-off and VTOL_LAND for auto land after the completion of the mission.

Is it possible that you are descending into your own wake? Try slowing the descent a bit.

Also, be sure that the plane is facing the wind when descending or you may have problems. You can either use yaw control to point it into the wind or use the weathervane feature.

Good luck!

1 Like

Is it possible your wing is starting to stall during transition?

1 Like

thanks for your reply
I will use the weathervane feature in future flights but I don’t think it happens because of that. How can I use the yaw control in the auto mode.
Is it possible that you are descending into your own wake? Try slowing the descent a bit. I did not get your point can you please elaborate on it for my better understanding.
cheers!

thanks for the reply .
I don’t think that this will be a cause of entering in the sabre dance because i was flying in the auto mode and it goes all good during the flight it happens only when there is a transition from fixed wing flight to the quad mode flight.

Watch around the 3:20 mark to see the plane wobble during landing. This can be caused by swirling wings or your own wake under the plane from the copter blades.

OK. I have seen a lot of people with problems that turn out to be stalls for whatever reason. Usually one wing stops flying before the other. Maybe at high AoA there is something due to the downwash others have suggested here.

Good luck. Let us know when you get it fixed :slight_smile:.

1 Like

we have made our custom design for the VTOLs so we know that this is not a condition of a stall. I will attach a video for your better understanding.
thank you for the reply.

1 Like

I have attached the video for your better understanding.
@cambull have a look at this video
@Eosbandi

https://drive.google.com/drive/folders/1BUpGRKtPJTE-Io5O2oq339IaBglPqM-t?usp=sharing

It only occurred for a short time so it is difficult to say for sure what caused it. It may be pitch PIDs or it may be wind or it may be wake or it may be the plane lowering the motor levels to descend.

If you see it happen more often, it will be easier to determine the cause. For example, does this happen in various wind conditions? Does it happen only during transition back to copter modes?

In the log, when the vehicle returns, the point just after the transition to VTOL has started a land descend. As Stewart suggested, the wobble may also be from a temporary stall as the plane slows.

thanks for your reply!
yeah, it happened only at the time of transition from fixed-wing to Quad mode.

I have also increased the D gain for the pitch axis of Quad mode but nothing changes.

should i reduce the speed first by DO_CHANGE_SPEED and then go for the transition.
@GregCovey

Looking at the Log Viewer, your transition is right where the green “1.84” label is for GPS Speed. You are already going quite slow and you can see the knee drops to zero shortly afterward. I suspect that the transition is trying to stop at some waypoint destination which is why your plane tries to abruptly stop instead of gliding forward. The mission does not read in properly with my installation of Mission Planner v1.3.74 on Windows 10 so I cannot see all the commands. I suspect that you can fix this issue in your mission plan by using a different approach. For example, do your transition first and then use a LAND command. You can also try using QRTL when the plane is further out since it has a parameter for when to transition from plane to copter.

Good luck!

Is there any way in a mission to let the plane coast to a hover after transitioning back to VTOL mode? My impression is regular RTL just cuts hard into a QRTL mode once inside RTL radius, and if the OP has a pitch tune issue the plane will still exhibit the same problem once in QRTL. I know because I’ve never quite tuned out a pitch overshoot problem in VTOL mode, and the start of every QRTL is a violent pitch over maneuver towards home position. The controller simply tries to rapidly capture the preset QRTL speed using VTOL logic, and proceed to home at that speed, regardless of how much energy you’ve got at the point of mode switch. That’s why I always fly the transition manually in Qhover.

Years ago, my VTOL mapping missions looked like this below. Waypoints 23 and 24 allowed for descending loiter turns before heading home. The VTOL was flying towards home when it transitioned to copter mode.