VTOL Nimbus FBWA to QLoiter Issue

I’m struggling with an issue where, when flight mode is changed from FBWA to QLoiter, the plane hovers but I have zero yaw/pitch control in the VTOL mode. Only when I manage to fight the plane down to around 3 meters above the ground does the yaw/pitch control come back. It’s almost as if a switch gets flipped and control comes back.

Unfortunately my logs didn’t save so don’t have those to share. Wondered if anyone knew what might be happening?

Hi Josh,

In the past, it was not recommended to change modes from FBWA to QLOITER because the craft would try to stop abruptly. It looks like this text has been removed from the Wiki but I still would not recommend it. Try changing modes from FBWA to QHOVER and then check for yaw control. You can always change to QLOITER after the craft has stopped.

It may also be that the weathervaning feature is fighting you until you get close to the ground. Maybe next time you can post a .bin file. Make sure you disarm after landing and the logs should be saved.


Hi Greg,

Thanks for the input. I’ll try QHOVER and see if that’s any better and also try to get a .bin next time. As for weathervaining, it’s disabled by default and I’ve confirmed I haven’t enabled by mistake.

My Nimbus is set up to give me a lot of authority on the Yaw/Pitch to deal with strong wind so it’s very obvious when its not working. I can give full left/right yaw and it does nothing after going from FBW to QLoiter. It’s almost like it’s still in “plane” mode until I get it low enough to the ground. Very frustrating.