Servers by jDrones

VTOL Auto takeoff issues

I’ve been testing a tiltrotor plane for fully autonomous missions: It takes off, flys, and lands without need for pilot input.
I’ve run into a quirk of the AUTO mode vtol takeoffs. In short, it’s using way too much power to get off the ground, and then throttling back to more normal levels once it’s a few feet in the air. In addition, it’s applying that power very quickly, which can cause issues if the motors can’t keep up. (I don’t have the motors constantly spinning when armed, due to safety concerns.)
I’ve only done 4 takeoffs in AUTO so far, and on the most recent one, things went wrong. It lept off the ground to about 5 feet, where it entered an oscillation, and came back down rather violently. Luckily the only damage was broken props and a clogged pitot, but nonetheless this is an issue I need to fix.

I’ve tried playing with the TAKEOFF_THR_MAX parameter already, but it doesn’t seem to have any effect on quadplane setups. It still goes to maximum power on takeoff, which led into the oscillation.
I’m not sure what parameters I should be looking for to change, but what I want to do is limit the takeoff throttle for VTOL AUTO takeoffs. Maybe a throttle slewrate adjustment as well? I can find these parameters for a normal fixed wing, but not their Q_ equivalents.
Any help would be appreciated on this.

Hi James,
I believe you could limit your values for Q_THR_MIN_PWM and Q_THR_MAX_PWM. Or just set Q_M_SPIN_MAX to an appropriate value; for example, if you set Q_M_SPIN_MAX at 0.80, your max. throttle will be limited to 80%. Let me know if that solves your problem.

Another parameter that might help is Q_ACCEL_Z. Reduce this value to limit the throttle takeoff aggressiveness.

Servers by jDrones