VR-Brain 5.2 problems with AC 4.0.7 and after upgrading to 4.3.3

I’m having problems with a VR-Brain 5,2 flight controller (installed on 810, 6 kg, hexacopter).
My question is: Wich is the latest AC fw version suitable for this hardware ?
I’m in doubt wheter if there are hardware/firmware compatibility problems or if I’m having an hardware problem on this board.
I was trying to solve some compass problems ( firmware AC 4.0.7), with drone disarmed on the table, when i found (Mission Planner screen) horizontal axis lean of about 45° and the red alert -Error pos. hortz variance-. So, for this and other problems a decided to upgrade-it to the latest fw version that was 4.3.3.
After that, all looked ok.
So I went to the flyng field, done accel and compass calibration (with GPS lock). All was perfect. So I armed, still at idle, I disarmed (for some last checks), then tried to arm again but I’d got yellow led flashing. On the mission planner screen -FAIL SAFE- Prearm: internal errors 0x1000000 I:174 Imu_reset.
So I preferred to stop all there for further investigations. What is your opinion about it ?(do you suggest to go ahead with FCU replacement ?)

Perhaps try downloading this version and use Mission Planners “Load Custom Firmware” to flash it to be sure you have the right firmware version.
VRBrain V52

Ok. I’ll this and let you know. Thanks !

I’m about to try to install -custom firmware- as suggested by Dave. Anyway i just made now one last check. I put to -1- LOG_DISARMED (as the error appear when disarmed ad goes to FAIL SAFE). It happens not random but systematically (i also get a -trottle below fail safe- prearm red but i think it’s fake as the radio tx was on.
Anyway now i’ve the data-flash-log file that you can dowload here from google drive. Please give it a check and let me know if you see something. Link:


No way. New firmware (loaded as custom firmware from ArduPilot firmware : /Copter/stable/VRBrain-v52 )
Same error.

warms up the topic.
Anyone know the cause of the error?
PreArm: Internal errors 0x1000000 l:174 imu_reset
PreArm: Board (3.5v) out of range 4.3-5.8v
Can’t find any clue anywhere
Please help.

With latest Arducopter 4.3.7, my VR-Brain 5.2 is fine.

Here are two screens (board is powered by USB and with just the firmware installed)

No bad IMU msg.

And the sensors:

possibly the compass sensor has been damaged