Voltage drop/failsafe issue!?

Hi guys,

well i been trying to get this thing in the air for a month on/off… I have a Carbon 550 bumblebee that had a KK2.1 on it, but I scrapped that for a pixhawk with gps. So I get it all set up, and get it all calibrated through mission planner and try and a test hover. No go! what happens is I start to roll on the throttle, and It gets light and slowly lifts off, by the time its an inch off the ground the low voltage failsafe kicks in and it plops back to the ground! it starts off with 12.38v showing on the OSD, and by the time im at half throttle its down to 10.5v and at 9.5v the failsafe kicks in and its done. If i slwly roll on the throttle and watch the voltage, it drops every second! If i stop adding throttle at just under the halfway mark when it shows around 10.5v and let off the throttle, it will slowly climb back up to 12.+V (12.3- 12.2) what the heck is going on?? this doesnt make any sense!? Im trying using a relatively new 3s 3000MaH lipo, and two 2200 3s lipo’s in parallel. It doesnt matter, they both act the same.

Im using the 3DR power module, Hobbywing quattro 20A ESC, bumblebee 930 kv motors, turnigy 9x radio, and PPM Encoder. I have a small turnigy 5v BEC soldered inline on the power module that runs the turnigy receiver. Its soldered in just after the power module circuit, but i cant see that being an issue?

I have the failsafe settings set up properly, as they are straight forward. I dunno. why is my voltage falling off so fast?? Oh. i am running the Hobbywing quattro as i received it. no programming or anything. i found posts where guys say they didnt have to do anything to them to run them.

can someone please help me?? Id really like to fly this thing sometime!

TIA< Ginnz.

Anyone? man, this has been a struggle. I mean, I plug my battery in (its a good battery), everything starts and arms fine. I raise the throttle to lift off and as i raise the throttle, the voltage drops, by the time there is enough thrust to lift into a hover, the voltage is around the failsafe amount and it goes into failsafe mode and shuts down. it just doesn’t make sense??

No one seen anything like this? is there something in the setup that could cause this? The only thing I can think of is that the default ESC programming could be an issue? But im looking at other guys posts on this esc and they are saying that the default programming is fine? (set to Nimh, etc…) Could my BEC cause this somehow?

im at my wits end here… I dont know what I can do?

Have you calibrated the power module?
The batteries may be good, but are they rated high enough (mah and C rating) for the UAV?

I took a reading with my voltmeter and made a small adjustment in mission planner settings so the voltage in the HUD matched what the volt meter said. It was only .5v out… And I had a KK board in the 550 before the pixhawk, and the batterys had no problem then. I was getting 10 minutes of flight. I just dont understand what the issue is?

the only difference since flying with the KK board is one new motor, and the hobbywing 20A quattro ESC. The original 550 bumblebee ESC were incompatible with the Pixhawk. I dunno. This afternoon, I tried again, except i didnt even try and hover. I only raised the throttle 25% or so and watched the voltage in the HUD drop… It starts out at 11.40v and just drops… in 10 seconds or so it will drop to the failsafe setting and shut down! Unreal, the throttle isnt even high enough to pull a hover and the volts just fall untill failsafe.

well get this… I disabled all the failsafe (voltage) settings, and set it up for a test hover. It did climb nice and hovered stable for 15 seconds or so then the motors slowly revved down so I landed it… Now this is driving me crazy! Is it possible there is a bad motor? Or a short somewhere in my system that is causing it to overdraw current somewhere? Its just the weirdest thing. The draw is a steady draw till failsafe, then when I lower the throttle back to zero, the voltage climbs back up to 11.(xx)… right where it should be.

im ready to shelve the whole unit… :frowning:


Well, you would think if something is shorted, causing all that load, that you would be seeing smoke somewhere. Anything getting hot? Also just for information, I have never gotten any of the 4 in 1 ESC’s I have, (ZTW Spider 20 amp) to work with anything I’ve tried so far.

Yeah, I know, if there was a short, something would burn up, and it wouldn’t be a slow steady drop, in conjunction with the throttle input… Im back at it again! I pulled all the wiring apart, and replaced that tiny turnigy bec i had in it to power the receiver with a bigger, better Castle bec… I looked over all the connections, it all looks fine.

and you say you cant any 4in1 ESC’s to work?? why is that? I choose the Hobbywing 20a Quattro because of all the posts i found where guys have stated that they are very good, and they had no issues… The original ESC this quad had in them did not work with the Pixhawk. (they have no name on them, and are just a small bare board). I could never get them to power up, they would go to mid throttle, and just stay there, not able to pull a hover. As soon as I swapped to the Quattro, calibrated to my radio, I had power. IOt appears to have plenty of power, If I could just get it to stop bleeding off all the voltage!!!

I will take it out again, and try a couple of time, Ill use fresh 4s 4400mah lipo, and then ill upload the log(s), I cant really read them, but maybe someone here can get something off them?

Come on guys, i really want to get this thing running, im just having one issue after another. this is the last one!

Great. Log file is too big… ;-(