Vibrations during flight

I am finishing tuning my drone during the flight, but all the time I cannot cope with the vibrations mainly occurring during maneuvers. I am attaching two recordings and bin files from ALTHOLD and LOITER flights:,,,

You can see that the recording from the ALTHOLD mode has less vibration despite the fact that the drone is much more aggressive.
Do you think increasing the ATC_ANG_LIM_TC=1 parameter could help?

Sorry, no time to look at the logs.

  1. Have you tried to fix the source of the problem, by reducing the vibrations?
  2. Have you tuned the notch filter?
  3. Have you tuned the copter?
  4. Why are you using ArduCopter 4.0? Update to ArduCopter 4.2.1.
1 Like

The good news is there is no clipping, at least in the two logs I looked at.

Vibration is a mechanical problem, so you can’t fix that with a parameter. You need to find the source.

Because the bulk of vibration will come from the propeller they can be impacted by airspeed. So the Alt_hold flight is showing higher vibrations because the quad is moving more compared to the loiter flight I looked at where the speed was usually below 2 or 3 m/s.

Vertical vibrations (Z) often means the track of the blades isn’t correct or equal. Have a look at your blades and make sure they’re all in good shape. Look for twists or nicks in the blades.

Horizontal vibration (X & Y) can be blade balance. Make sure the blades are all centred on the motor shafts. If they are bigger blades you may want to look at their physical balance. RC planes folks have been balancing their blades forever so if you aren’t familiar with the process check youtube for a technique that will work with your blades.

Motors can also be a problem but you’re likely going to feel that when you turn them, or hear it. And props are easier/cheaper to replace, so better to start there. That said, double check for any lose screws or frame mounts. Anything that can wiggle can create a problem.

1 Like
  1. I have tried everything when it comes to balancing the blades. I purchased three pairs of different propellers: Sunnysky EOLO CN17x6.2, T-motor MS1704 and Tarot 1760 TL100D10, choose the ones that generate the least vibration. To my surprise, Tarot was the best. Yes, Tarot propellers are heavier than Sunnysky and T-motor, so the amperage consumption is about 4A higher. Below are the charts for comparison:

Which propellers do you use, which do you recommend?

2, 3. Yes, my hexacopter is after a long and precise tuning. Below are the tuning results:

  1. I was using Copter 4.2 during the uploaded flights.

I include a picture of my hexacopter for better understanding:

Take the camera/payload off (including the gimbal and mounts) and do a test flight. See if that changes the vibration. At least that might help figure out where the problem is. If it is the camera and gimbal then you need to see if you can either secure it better, or if the images/data are unaffected then maybe this is something you live with for that camera setup.

1 Like

I made some comparisons on the graphs to see what might be influencing the increase in vibration. The conclusions are that mounting a gimbal with a camera is an additional weight (1.1 kg), so the motors rotate faster, which generates more vibrations, it is obvious. However, I don’t understand why the LOITER mode generates higher vibrations, despite the fact that the hexacopter in this mode flies slower?

Below are the charts:

because the loiter mode uses extra PID loops that are sensitive to noise. Stabilize uses less PID loops

How do you rate this level of vibration?
What are they in your drones of similar size?

Vibrations without the camera look good to me. As I said, there’s no clipping.

Are you having issues with the camera and gimbal? Are they rubber mounted? Maybe you should try a firmer rubber mount.

I used 12xTL10A05 in the tests described above.

I have noticed that the vibrations increase strongly in windy weather because the drone makes a lot of aggressive stabilizing movements which result in vibrations.

Is there any parameter that smoothes and delays these wind-correcting movements?

Decrease the filter frequencies. But do it slowly.

Do you mean these two filters? What values would you suggest?

Propellers: 17 "
The span of the motors: 100cm
Weight of the drone: 7.3 kg

I think you should check or add external damping measures to the flight controller. Reduce the filtering frequency, but you adjust it higher. In addition, the PID parameters are unreasonable, and they are inconsistent with my experience. It is very true that the parameters cannot be adjusted according to the recommendations given by the software, which will cause the aircraft to be very dull, or it may be my hand feeling problem,
As for vibration, I think you should check the clearance of the arm and eliminate them. The ideal vibe XY should be about 10
All the above come from personal experience and robot language translation

The flight controller is based on four special foam pads that were included with the Pixhawk 4 set.

I have done the autotune many times. In althold mode and in loiter mode. The PID values were just fluctuating around the values that are finally entered. I would like to add that Autotune was turned on with a starting weight of 6.2 kg (without gimbal and Sony A6400). Please write down which values do you think are wrong?

The arm mounts that I use have a special screw that compensates for any clearance on the arm. It’s tightened well in all 6 arms. I would like to add that the engines are balanced, the only thing that can be objected to are the propellers, but so far I haven’t found better ones. If you can recommend any, I’ll be glad to hear from you.

So far what I did is lowered the values:
INS_GYRO_FILTER = 22, according to the diagram in the instructions for propellers 17 "and:

For your size, I think the value between 60000-80000 is more suitable for ATC_ ACCEL_ R/P_ MAX
For INS_ Gyro: I don’t think a little change of this parameter will solve anything,
In addition, I am pessimistic about automatic parameter adjustment. I always adjust PID manually, and automatic parameter adjustment often gets strange results
Maybe you can try my experience: at alt_ In the hole state, take off at an altitude of 3-5 meters, the remote controller quickly inputs a large range of pitching or rolling actions, and adds ATC_ RAT_ PIT/RLL_ P. Until the acceleration sound when the brushless motor changes is heard, it is an appropriate value. At this time, the UAV may vibrate several times after completing the action before convergence. Then increase ATC_ RAT_ PIT/RLL_ D. Let it not vibrate. P increases by 0.02 each time, D increases by 0.002 each time, and I is set to the same value as P,
ATC_ ANG_ PIT/RLL_ P is configured as 4-6, and this U

1 Like

I’d love to try your tuning method. I know that characteristic sound of the motors. Sometimes it was after autotune, sometimes it wasn’t. Unfortunately, now the drone is immobilized because one motor burned out, I hope it is not due to the new PID values. I’m waiting for parts.