Vibration and flight video of gasoline helicopter

Hi guys.
Now I’m trying to fly a Pixhawk on my Gaui GX-9 helicopter.
In Stabilize Mode, I fly without any problems, but when I switch to Position Mode,
The helicopter rocks up and down.
The GX9 has a lot of vibration.
So, I think the vibration is affecting the F / C.
I’ll upload a link to the video, so I hope you guys have a look.
I need a lot of help with these problems.
Please help me !!

Could you please post a parameter file exported from it, and a log file? I looks like the collective pitch is oscillating due to ACCEL_Z_P being set too high.

The GX9 is a very vibration-prone heli as the F-50 engine is not smooth. It will take a very well engineered mount to isolate vibration in that machine and likely have to add some mass to the flight controller to help damp vibration. Your engine is running exceptionally poor - sounds and looks like it’s way too rich as you are getting a lot of tail twitching from engine misfire. But again, the F-50 is a touchy devil, run it too lean and it will stick the exhaust valve or score and seize the piston. Run it too rich and it shakes the whole heli.

1 Like

Hi Chris.
Thank you very much for your reply.
I will send my parameter and log file.
I hope you to take a look at the problems of my parameter,please.
And my engine seems to have to be adjusted again.
Your opinion is that my engine is too rich?
So I will try to adjust the engine again today and lower ACCEL_Z_P.
I really appreciate your help so much.
Can I ask you a question if you have any questions?
I will continue to tell you the status of my helicopter.
Have a nice day!

ru180418.param (13.8 KB)

Chris, Here is my log file.
2018-04-17 (768.0 KB)

I haven’t flown a gas/nitro helicopter in a very long time, but Chris is spot on. That engine doesn’t sound happy at all.

Another thing I noticed is the head speed doesn’t sound right either and I’d wager you are pulling some serious pitch to compensate.

If that’s the case, running a higher head speed will get the engine up on the RPM curve where it is happy, you will need less pitch, collective changes will be smaller, the tail rotor and cyclic will have more authority, and the aircraft will be easier for you and the FC to control.

1 Like

Right here is the problem with the collective pitch oscillating. This should set down to about .28 for big fuel heli

I see you are flying the helicopter with the defaults and it is not tuned. Please follow this guide and tune your rate controller. It is lucky it even flies with the defaults and I would NOT fly it in Loiter anymore until you tune it. You run high risk of crashing it with the defaults, which work ok for a small heli, but not a GX9:

As OldGazer said, your engine does not sound good. It is not cleaning out properly as you roll throttle. Vibration is not the problem, however. I played back your tlog and the vibes are fine. The main problem is that you do not have the rate controller tuned, and ACCEL_Z_P is set way too high.

The GX9 is designed to run 1,160 rpm headspeed. It’s Gaui’s “answer” for a gas UAV heli. I had one for awhile. The sound of the machine is deceiving because it’s a four-stroke and the exhaust consists of a bent straight pipe with a spark arrestor screen welded over the end of it. So they sound kinda of “blatty”. It should have a governor on it, but it was hard to tell if it was working or not. @retromix pulled a lot pitch on takeoff before it got up to full headspeed and I didn’t detect the sound of the governor “grabbing it”. So I suspect it’s being flown just on the throttle curve. And the high point of the curve is set at 50%, which is way to low if you really pull a lot of pitch with a load on it - it won’t open the throttle all the way.

3.6-rc1 should be coming out next week. I would highly recommend installing that and set up the new five-point throttle curve that’s in it. I’ve been flying 3.6 right along thru the development stage, and I haven’t found anything in it that is bad for heli’s. With five points instead of three, you can set a lot more accurate throttle curve for your gasser.

1 Like

Hi! Chris.
Thank you very much for your reply.
As you said, ACCEL_Z_P was set too high.
I changed the setting from 0.5 to 0.2, and in Position mode
The vibration is gone.
And my parameter is close to the default.
I honestly do not know how to set the parameters. It’s very difficult.
I’ll modify the parameter again and let’s try again, as you can tell.
And I do not know how to set up the gasoline engine for the first time and set the needle.
(I used to have a lot of Glow engines in the past, but this is the first time I have a gasoline engine.)
As you can see in the video, I often hear the sound of the engine being compromised.
I wonder if the sound sounds like it’s because the combination of gasoline and oil is not right.
Anyway, I will keep trying.
And I want to know if Autotune is applied in helicopter.

And I did not have a governor.
And please let me know how to set up the Throttle Curve.
The 3.6-rc1 you talked about is very much expected.
Let me know if it is released.

I’ll set it up again and fly it to you.
Thank you so much.
Have a nice day!

Hey, Oldgazer.
I appreciate your advice.
I’m not familiar with gasoline engines for the first time, but your advice is very helpful.
I want to continue helping you.
Have a nice day!

@retromix It’s outside the scope of this forum to explain engine tuning. Glow engines are typically run very rich because they are methanol/nitro burners. Gas engine tuning is different. I’d recommend getting the manual for it from Gaui which explains what to use for fuel/oil ratio and tuning. Those engines are quite touchy - get them too lean it will overheat and seize the exhaust valve or piston. They normally misfire at idle but as soon as rpm starts to increase and load is applied it should clean out and start to run smooth without misfiring.

Autotune is not for helicopters. They must be tuned manually. You can study how to tune PID’s for your heli here:

To make it easier to set your parameters for your heli I’ve been recommending to download and install QGroundControl from here:

QGroundControl is easier to make settings than Mission Planner is, and doesn’t have any confusing setup pages that are primarily designed for multicopters. If you haven’t watched the instructional videos I would recommend doing that. You can see those here, and I use QGroundControl for the ground station in the videos:

But before you tune PID’s, it’s kind of important to know how fast your engine is running to make sure you are at the correct headspeed. So you need to get some sort of tachometer to measure it - either telemetry so the headspeed is shown on your RC radio, or use an optical tach and run it on the ground to adjust your throttle curve. It needs to be at 1,160 rpm for the GX9 with the heli in hover. And with no governor when you load it the engine should not bog down. This is a little extra instructional video I did on tuning the throttle curve with ArduPilot, using a real heli to show how it should work.

3.6-rc1 will have the five-point throttle curve I explain and demo in the video:

1 Like

Hello? Chris
Prepare to set the PID as you told me today
I tried to fly.
I tried to adjust it with the dial of my Futaba Transmitter,
I could not set it because the tail was shaking like a video.
What parameters need to be corrected for such a phenomenon?
It looks worse than when I first flown.
I need your help.

The engine did not sound all that bad under load in that video. Just be aware on gassers that engine misfire will cause a side-to-side tail jerk.

These parameters adjust the tail

Since the tail is not all that great right now with the defaults, you could try my tuning parameters and see what it does:

1 Like

Hello? Chris.
I received your reply well. Thank you so much.
I tried applying this parameter value you suggested this morning, but Tail is still shaking a lot.
So I modified the parameter arbitrarily to fly.
The result was not bad. Tail seems to be stable.
Here we upload the parameters and logs we applied today.
I hope you take a look.
So I tried to fly to position hold.
It seems to be fixed but not stable enough.
Rather, it feels better to hold in Loiter mode.
What paramater do I need to fix to be perfectly in position hold?
Please teach me.

I tried to fly the Mission.
I flew all four points and the helicopter flew sideways without flying straight. Why is that?
And when the helicopter finished the mission and landed on the ground in automatic landing, The copter was touch the ground and jumped up, and I chaged stabilize mode.
In the video, the last scene was not missed.
Please watch the video.

Chris! Thank you for your help.
Y.S Kim From Korea.
Log File.


I’m using a lot of VFF, which could cause it to shake back and forth some, so reducing that to around 0.06 might help it. I run a short throw on my servo arms so I have full resolution on the tail servo to provide smoother action on the tail. That’s why I use that much VFF.

Your tlog doesn’t really indicate why the heli jumped off the ground when it auto-landed. But I think your throttle curve has a problem

And this setting

You are using a 20-20-50 throttle curve and your critical is set to your throttle max on the curve. That H_RSC_CRITICAL should be set the throttle value that the heli can no longer fly at. So if at 25% throttle it will no longer maintain enough headspeed to fly, it should be set to 250.

In my experience, somewhere around 250-280 is right for most piston heli’s.

The three-point throttle curve really sucks. I know why you have the top of the curve set to 500 - it will overspeed the engine if you set it to 1000. It looks like you are using very little negative pitch, which is very common for UAV heli. But that old three-point throttle curve doesn’t work properly with it. Randy has indicated 3.6-rc1 will be out next week and then you can set the new five-point throttle curve, and this new throttle curve made by @bnsgeyer works awesome for piston heil’s!

The new throttle curve has these settings:

And for your heli for the first flight I would set them to:
And then fine tune the H_RSC_THRCRV_50 and H_RSC_THRCRV_75 to get the right rpm in hover. Once you have the right rpm in hover, then load it by doing a full-collective punchout. If it bogs raise the H_RSC_THRCRV_75 a bit. If it overspeeds on a full collective punchout, lower the H_RSC_THRCRV_75 a bit.

On landing, when you reduce collective pitch, if the engine speeds up as the pitch load comes off, reduce the H_RSC_THRCRV_25 a bit.

This new throttle curve made such a huge difference that it makes governors about obsolete for piston heli’s. I’ve found lately that I just leave the governor switch on the radio in the “off” position and don’t even use the governor. It will make a big difference in the throttle response for your gas heli, as you will have 100% engine power available on high collective loading, and it will provide much more accurate throttle control in the critical phase of landing/takeoff. Properly set, it will maintain the headspeed perfectly, and your heli will be a lot happier.

I kind of think your tail jerking is the throttle over-reacting on collective pitch change, due to that old three-point throttle curve. And the torque change from it causes the tail to jerk side to side. Piston engines have far more rotating mass in the crankshaft, flywheel and clutch than electric motors do. And every time a torque change is made to that rotating mass, it causes the frame to jerk. With a very powerful engine like I have in my 766, on a full collective punchout where the engine goes to wide open throttle it takes full rudder to hold the heading. Which makes them really fun to fly compared to electric, as they are a real “pilot’s heli”. :grinning:

The F-50 is a pretty good-sized engine with a pretty heavy crankshaft. So I’m almost certain that tail jerking is being caused by the throttle curve applying linear throttle response on what should be a fairly flat part of the throttle curve.

Hi. Chris.
I’m sorry I did not answer the test for a while.
I installed the Firmware you mentioned at 3.6 this time.
I installed and made a mission flight. Put my parameters and log files here.
Please check it.
By the way, there is something strange. At the end of the first tlog,
The helicopter began to descend quickly as it switched to position hold mode.
I wonder why the flight mode has changed.
I was using Dragonlink. What was the problem?
Please check my parameters and tlogs and see what the problem is.
I will continue to test the flight and report the helicopter status.

parameter :

Tlog :

The reason it is using Pos Hold is because that’s what you have set up for one flight mode


You are getting some clipping on the IMU’s. But it appears to be mostly when the engine is idling on the ground. But the y-axis vibes are a little high in flight.

For some reason your flight plan did not load to the ground station. So I could not see the details of the auto mission. So it is hard to determine why the heli descended quickly when it went to Pos Hold. It could be you had the collective pulled down from center on the RC? Which will not affect it in Auto, but once it switches to Loiter or Pos Hold, it will.

Vibration can also cause the heli to handle badly and wander around more than it should. Especially when you are getting some IMU clipping. I would look at doing something a little different for your mount to try to get the vibes on x, y and z down below 10 in flight. With the engine idling on the ground they are always going to be high, especially with the F-50 engine. But in flight you will get better performance and handling if you can get them below 10.

Hi, Chris.
Long time no see
I was so busy setting the gas helicopter, GX9.
There was a lot of work, but there was a problem with the engine.
So, I went to Gaui to solve the problem.
However, Gaui says that they have never used Pixhawk to fly.
They must tell the governor to apply.
Gaui says you have to fly at 6500 RPM.
So, we’re going to apply the governor to our GX9.
But I have never used a governor.
I would like to ask you for your experience.

  1. I want to know how to set the parameters to apply the governor.
  2. I want to apply FUTABA GV-1 and tell me what your opinion is.
  3. Or tell me the governor you can recommend.

Chris, I need your help. Please.

The GV-1 is fine if you have one. But they are not supported anymore by Futaba. I can recommend the Aerospire MultiGov Pro, as it is a current production governor and fully supported by Aerospire. It was made as a replacement for the GV-1 when Futaba discontinued the GV-1.

If you have a GV-1 I hope you have the manual for it for setup as it requires a throttle curve to work. And the new five-point throttle curve will work for it.

The only parameters you’ll need to set in ArduPilot is use H_RSC_MODE 3, set the five throttle curve points for proper feedforward (fly without the governor first and get it pretty close). The rest of the setup is in the governor itself - teach it the endpoints of the throttle, decide whether or not to use stick switching, set up a separate channel for your governor on/off - the GV-1 or Aerospire has headspeeds that can be set but will not apply to the GX9 because it requires 1,160 rpm headspeed (6,500 rpm engine speed) and there is no other options for it.

If you use a Aerospire governor you can set the default for the governor control to be governor off, and idle 1 is governor on. That is what I prefer, as I would rather take off on the throttle curve and switch the governor on in-flight. The throttle curve is smoother for takeoff. If you are using any sort of autonomous takeoff (not recommended) with a governed piston engine you have to set your runup time to allow the governor to take over from the throttle curve before it slams in collective and lifts off. The auto-takeoff is hairy and not smooth at all - or at least not what I’d call smooth compared to how a human pilot does it. The autopilot can cause a flameout the way it handles the collective and you’ll definitely want the governor engaged and active or the autopilot will try to lift off on the throttle curve and lose control of the heli due to not enough tail authority and headspeed too low. I’m not sure if you were using autonomous takeoff, but thought I’d mention that so you’re prepared for it if you do.

Again, the setup in ArduPilot is simple - Channel 8 switch on or off (this is your throttle hold). Mode 3 throttle curve. H_RSC_IDLE set so the engine will idle. Whatever it takes to fly it without the governor. That’s it. The rest is all in the governor programming.

1 Like

HI, Chris.
Thank you very much for your quick reply.
So what’s the best way to maintain a 6,500 RPM without using a governor?
I think I should be able to maintain 6,500 RPM and only raise and lower the helicopter with the Pitch, is that right for me?

If so, I want to know if I can set the throttle curve to 6,500 RPM.

For example, H_RSC_THRCRV_50 has a figure of 6,500 RPM of about 500
I would like to know if H_RSC_THRCRV_75 and H_RSC_THRCRV_100 should be set to 500 as well.

I want to finish setting without using the governor.
Chris, thank you so much for your help.
Have a Nice day !!
Thank you.

Well, it kind of depends on the pitch curve. But assuming you have -2.5 to +11 degrees of pitch the heli should be just approaching light on the skids at throttle curve 50. It should go airborne between throttle curve 50 and 75.

If you are running 500 at throttle curve 50, the load on the engine normally increases slightly as the heli becomes airborne in hover. So throttle curve 75 has to be set slightly higher than 50. And throttle curve 100 should be at 1000 (100% throttle) or you won’t be able to use the full power of the engine and it will bog out on a full collective punchout. If you set the throttle curve flat the engine won’t be able to handle varying pitch load. As the pitch load increases, the throttle has to open to increase engine torque.

So if you think throttle curve 50 set to 500 has you at 1,160 rpm headspeed (6,500 rpm engine speed), then I’d set throttle curve 75 to 60-65, and throttle curve 100 to 1000 and try that. If engine speed increases when you go into hover, then drop throttle curve 75 a bit. If it bogs when you go into hover, then increase throttle curve 75. But leave throttle curve 100 set to 1000 or I guarantee you the heli will fall out of the sky the first time you bank into a tight turn and max out the collective.

Also, in my experience with the GX9, this is the problem with that F-50 four-stroke engine. My big gas heli’s hover at only about 33-35% throttle. By the time you get to 50% throttle you can’t increase the manifold pressure much more by going to WFO. At 50% open you’re probably already at 24" of manifold pressure and WOT is only get you 28-29" at sea level without a supercharger.

That engine is severely under-powered for that helicopter and they top out at about 70 mph with the throttle wide open and it just doesn’t have any more power to go any faster. Gaui didn’t spend a lot of time designing the induction and exhaust system for that engine. The exhaust is basically a bent piece of pipe with a spark arrestor screen welded over the end of it. And the carb on that engine is way too small. So you definitely don’t want to scrimp on throttle with that thing or it will just bog out and vibrate really bad.