Very poor quality connection link after upgrade to MP 3.1.15

I don’t know what happens with connection link through 3Dr radios but now I have a very poor connection link (less than 16%) and a lot of packets lost. That happens at home, with Air and Ground radios close together and with no problems of noise nir remnoise.

I don’t know exactly when that start to happen but I think I have that problems after Mission Planer Upgrade to 3.1.15 or Arducopter and Arduplane firmware upgrade to 3.2 (I did all at the same time).

That happens both with my airplanes and quadcopter. I am using APM 2.6 and 915 3DR radios (original), 915 RC timer radios or RDF900 radio modem. The same issue in all cases. I didn’t change any config parameter related to serial connection from previous versions of MP or Arducopter-Arduplane.

I tried to upgrade radios firmware again (Sik 1.9) but I still have the same problem. By the way, radios were configured with Airspeeed 48, ECC, Mavlink protocol (more or less the default configuration, that also has been tested).

Any help is welcome.

After some test with previous MP versions I have detected that this problem with Mavlink quality actually started with version 3.1.11. With MP 3.1.10 link quality is 100% and after upgrade it to 3.1.11 it drops to 16%, as I reported in my first post.

I also have checked MP Change Log and I notice that version 3.1.11 included a new Mavlink library.
Am I the only one with this problem? After searching for solution in APM forum I can’t understand what is happening.

Please, hope that some one of developer team could give me an answer about it.

Thanks in advance

Don’t know that Mission Planner has control over the radio power. The upgraded Mavlink library is software only and not related to the radios.

Sounds like one of your radios may have gone bad.


Hi Mike,
Thanks for your comments.
Radios are fine and there is no hardware problems ( you can see rssi and noise valuees in the graphic above)
I have the problem when I check Link stats in mission planner, with quality below 20 % and too much packets lost. That only happens in MP 3.1.11 or higher. I did the same test with 3.1.10 and quality was 100%. So I am sure that is a software bug in Mission Planner.
I opened an issue in Github regarding this yesterday.

I see what you mean. I connected to Mission Planner and it showed 1% for link quality and was dropping lots of packets.
I hooked it up to Droid Planner and it shows link quality at 100%.


I´m having exactly same problems. Plane only 2-3 mts apart from pc and link quality shows less tan 15% and a lot of dropped packets. Rssi look good so I have no clue of what is going on. I also believe it changed on updating misión planner.


Hi Hernan,

This issue was resolved upgrading Mission Planner to the latest version, where this bug was fixed.

Hope it helps.

thanks osmunda, you mean 1.3.18 ? I did have I think last time I tried to find what the problem was. I will check today.


I just tried with 1.3.18 and no joy. link quality is really low between 23-16 with a lot of dropped packets. radio firmware is 1.8.1 and arduplane 3.2 .


how are you connecting to the plane? and also please make sure you upgrade to MP 1.3.19

Michael telemetry is hooked in usual way to apm. I checked with my hexa and keep having same results. Link quality low, but I do not see telemetry going bad on tuning window or refreshing of data. It looks like link quality is not showing real values. I wil try to get a screenshot tonight.