Very New to ArduPilot and Stumped

Hi everyone,

I’m a complete newb to ArduPilot, but from the YouTube videos I’ve seen it looks like it might be for me.

I picked up a used Eachine Racer 250 early in the pandemic and it sat in a box. I’m feeling like summer would be a good time to try and get it working. When I bought it I was told it worked, but it was missing the battery. I’ve got a battery now and I have partially disassembled it to look at what I have.


Eachine Racer 250 body
4 individual ECs (probably 12A and likely these as the drone is a Eachine 250)
Props Removed for Safety
OP GPS module
CC3D Revolution ARM STM32F405 based flight controller
Taranis X9D Plus
FrSky X4R
Fat shark Immersion RC antennas x2
FPV - camera and transmitter unknown, but I can pull things apart more to find part numbers I’m sure.

I have ArduPilot Copter (4.07) installed on the CC3D Revolution FC.

I’ve got the receiver and transmitter paired, but I don’t see any Radio input in MissionPlanner. I’ve got it wired on SBUS - or I think I do. I’m following this diagram:

In order to get the receiver to pair I need to connect the battery - once I connect the battery it will pair.

When I connect the battery the ESCs beep at me telling me there’s a problem - well 3 of the 4 - I’m not sure but one motor/ESC may not be working.

I’ve read that it has something to do with not giving the ESC the correct throttle - but I have no idea what I would do to fix that.

I’ve run the ESC calibration and they make happy sounds during that. But when I disconnect the battery and connect it again, back to constant beeping.

I do not have a telemetry radio connected on the telemetry port - I have a couple, but I need to change the connectors from 1.25 mm to 1.0 mm JST.

Sorry for the long post, but I’m stumped and not sure what to do next.

Constant beeping is normal and OK.

How did you get the Arducopter firmware on the CC3D Revo?

By following the wiki?

It was a bit of a pain, but yes mostly like any other controller.

I had to solder the DFU pins on the back - trying to jump them with wire wasn’t working for me.

Once it was in DFU mode it was easy to install following the standard instructions. I’ve since tried using iNav to flash firmware using DFU mode but it doesn’t seem to work for me, so I have to take the whole quad apart to flash anything.

1 Like

As a follow up to this post in general.

Currently I moved the quad to iNav as the UI was a lot easier to understand and work with for testing and figuring things out.

I was able to flash the ESCs to BLHeli latest. I also got the quad to arm and lift off, but it is very unstable so mow I’m doing some repairs on broken parts.

I’ve also got the FPV system up and running. I may give ArduPilot another go - I’m running a RC of iNav 3.0 so I have to take the quad apart to flash an update of some kind anyway.

I converted an eachine racer 250 to ardupilot by using a microAPM controller and wrote a blog post about it. I don’t know if it is helpful to you, but here it is. [link]( Blogodrone: Converting the Eachine Racer 250 to APM Controller)

The CC3D is old but it will still run circles around an APM :smiley: And it’s supported with the latest version of Ardupilot. APM is left in the dust with 3.2.1.

Today you can get a H743 based FC that’s not much larger than the Mini version of the CC3D!

I know, I did this conversion over 5 years ago in January 2016. If I did it today, I would likely use an F4nanoV6.

1 Like

Not a bad choice. I have 2 of those, one still flying a Plane and they are somewhat limited in capability and features. I switched to Matek H743-Mini and Kakute F7 Mini V2 for small builds. But the Nano’s price is right!

What firmware version are you using? On, there don’t seem to be firmwares specifically for the Revo. Did you just use the revo-mini version?

I think that is what I used.

If I recall the mini and the full size are the same hardware just packaged differently.

1 Like

Got it, I realized my problem is that my board doesn’t have some of the components that the original Revo had (baro, compass), so that’s why I was throwing errors. Thanks!

As I still have three CC3D minis here, I am using this little tool to bridge the pins.

regards - KH