Very little thrust exept in stabilize and motors pulsing


Can anybody give me a clue of whats wrong with my quad. it sounds like every motor “pulses” quickly during flight, or should i say hovering,
i have only just hovered the quad since the problem started. The quad worked good with older firmwares, i flew it alot for 6-8 month ago but after an upgrade of the firmware the problems came. I am bad at analys the log files but if i understand it looks like all engines pulses (i dont know if its thew right word) and the rear left motor works more than the others. also i have 2 compasses and if i understand its a problem with the external compass.

Also, the biggest problem that came with the firmware upgrade is that the quad lost all thrust in every flight mode exept stabilize, even if i give full throttle the quad just go up slowly and in a decent it is hard to stop it from sinking.

when i first made the firmware upgrade and the problems started i had an amp2.6 in the quad, now i have changed to a Pixhawk and still have the same problem.

I have a few screenshots from the log that maybe can explain what i not can express with my bad English.

vibrations seems ok -> … s.jpg?dl=0

compass seems that its something wrong with MagZ in the external compass -> … 2.jpg?dl=0

Biggest problem, the quad lacks of thrust, as you can see in these picture, in althold throttle in do not affect throttle out to any motor much but after about 3.5min i switch to stabilise and then just little trottle in affects a lot and during the whole flight it seems that one engine (chan2 out) works a lot more than the others. -> … t.jpg?dl=0

Has anybody time to just give me a hint of what can be wrong with my setup i would be very happy.

if someone is interested i also have this links:
tlog of the flght -> … .tlog?dl=0
bin log from the pixhawk ->
video from the flight -> … 5.MP4?dl=0


I have had this problem for about 4-5 month now, i have read a lot forums, tested a lot and yesterday i posted this question on 2 forums. Today i found the problem, it was one of my esc´s that have lost the calibration. now it works as great as it did in the summer. Hope this can help someone else also…