Servers by jDrones

Very hard landing (crashed landing gear) when RTL after 10 minutes succesfull maiden flight


(Pascal) #1

Hi,
I did my first flight with a pixhawk (original) controlled 12 motors dodeca hexacopter. All went well (stabilize and Poshold modes) until I tried to land with RTL mode. It went to approx 20 meters (which it should) then got to RTL location and start to decent… then it went wrong. For one reason or the other my hexa suddenly dropped and before I could react with going to stabilize and giving full throttle it basically went thru it’s landing gear… no other damage but it was really falling… I have the latest versions uploaded and it is not my first build… it is however my first crash hence my novice level of experience with the logging… I looked myself and noticed the following “strange” symptoms:

  • at the moment of crash: CTUN.Alt -3m? while GPS.Alt has an continue delta of 4 to 5 meters with CTUN. BARAlt
  • CURR.VCC looks normal with the exception of dropping after 6 minutes of flight without any problems

would highly appreciate if somebody can take a look at my logging, or give me some advice in what direction I have to look… I did already check the Readme first of this topic.

Thanks,
Pascal


(Igor) #2

Hi,

I am no expert in looking the logs, but here is what I noticed.
You should look at CURR.Volts.
Correct me if I am wrong, as I assume you have an 8s battery, the starting voltage was 33,29V (4,15 per cell).
In the moment you switched to RTL it was down to 25,6 (3,2V per cell) and on the peak of the RTL climb 24,66 (3,0V per cell) and then it dropped quickly 17,6 (2,2V per cell) while you motors tried to keep it in the air.
Finally, without the load, the battery was at 20,5 (2,56V per cell) which is way too low.

I would check the battery after this as the voltage shouldn’t drop under 3,0V.


(Pascal) #3

Hi Igor,

thanks for your answer.
I am not using a 8s but a 8000 mah 4S, so this cannot be the issue…


(Igor) #4

Hi Pascal,

Well, your logs show 33,29V starting voltage, that’s why I assumed you have a 8s.
Did you calibrate your power module? Again, I assume you have one.
Have you checked the battery voltage after the flight?

You said you have a 4s battery, so if I divide the volts from your logs by 2 (33,29/2=16,65V) , I get the same thing for a 4s battery.
So it seems to me it is a depleted battery which was the cause.
I could be wrong, so please someone correct me if I am.


(Mike Boland) #5

It is pretty clear looking at the CURR values, both voltage and current, you just ran out of battery.
The Battery Sensor is obviously not calibrated correctly if you are running a 4S but Zero volts is Zero volts and does a dive just before you hit Stabilise.
Current is constant, with a slight rise due to falling voltage, until there is nothing left and it dives as well just as you hit Stabilise.

Your rig is consuming 24A at hover.
Have you calculated the consumption over flight time?
What did the battery need in recharge?


(Pascal) #6

Hi Igor & Mike,

thanks a lot for your answers. I have been banging my head against the wall (figure of speaking) because this is really a stupid mistake…
I have build my hexa with a double lipo system based on a airbotpower system, which allows to build a redundant power system.
So normally, I would have 2 8000mah 4S lipo’s. For my maiden flight, I used only one… When I did my design, I made a calculation to have an almost 20 minutes flight time, but based on 2 lipo’s of course… when I was flying, that was what I had in mind (only used a timer and trusted on my configuration)… Did not check it yet, but I think I calibrated based on 2 lipo’s instead of one…
so, the positive thing is that this happened when it was landing and not 20 mtrs high, because this would have resulted in more damage then just landing gear…

last thing: I would consider 24A at hover normal for 12 x 960Kv motors and an approx 4kg rig?

Thanks again!


(Haydar Biyik) #7

Hi Pascal,
I would like to use a pixhawk to fly my X12 Hexacopter too.
Currently I am using Mikrokopter.
What do I need to modify to enable 12 motors?
Do you have a special compiled ArduCopter version and can you share the information?

Thanks and regards
Haydar


(George Muirhead) #8

you just fly as a hex with motors paired.


(Pascal) #9

George is right, I just used y-cables to pair motors… did not had time for many months now to work on my copters, but I believe I used Y-frame for setup…