Vehicle missing on Flight Data tab, and now on Plan tab

Ok, haven’t updated Mission Planned in a few months, but I just did the other day. Since this new update, 1.3.72, I do not see the vehicle in the “Data” tab, which used to be “Flight Data”, and now I see the live vehicle on the “Plan” tab… How do I get this back to the way it was? Is there a setting to change, or is this a change in Mission Planner ?


can you please turn on the console
help > show console
then restart MP
and then connect as normal, and show me whats in the console?

or post a log from c:\programdata\mission planner\missionplanner.log

MissionPlanner.log (742.8 KB)

John, could you give MP beta a try? and thank you for reporting this.

to get beta, click help>update beta

if this tests ok for you, i will likely release a new MP version

OK, I went to HELP>“Check for Beta Updates”. it pulled some changes down, updated MP. It now says 1.3.72 Build 1.3.7471.1576, don’t recall the build version from the other night. It restarted MP , and initially I didn’t think it worked, so I closed then reopened MP and it worked, but only one time… The vehicle , Plane in this case, did show up on both tabs, but I have not been able to repeat.

I have tried this on both Copter and Plane. Did I correctly DL the Beta?
Log below

MissionPlanner.log (453.6 KB)

yes you got the beta, the build number shows it - 7471

could you provide the tlog for one of the failures?

its something to do with either ADSB or AIS. but i cant track down which.

Didn’t have time yesterday, but had a few minutes to do so today, HOWEVER… When I powered everything back up the vehicle was shown on the Data tab. Tried on several units, (2) Pixhawk 2.4.8, a Matek 405-CTR, and a Cube Orange. They all show the vehicle on the Data tab.