Servers by jDrones

Vehicle did not respond to request for parameters


(Corrado Steri) #1

A in topic i get the following message from Qgroundcontrol “Vehicle did not respond to request for parameters”.

Vehicle looks connected as i can see battery state, gps state and position on map but looks like it doesn’t download parameters.

Uing Ardupilot 3.5.5 and companion with mavlink and Qground control V3.3.0

Mission planner connects and download parameters with no probs. Any hint on where i am making a mistake?

Connectin Qgroundcontrol trough USB it connects fine and downloads parameters.

When i try trough UDP it doesn’t, i am sure all connections are ok because same exact configuration connect and downloads parameters trough Miion Planner.

Maybe a serial speed param to set? Now Serial 1 /Telem 1 wich i use to connect to mavlink on companion i set to 115200 baud.

regards,

Corrado


(Joe Marrone) #2

I’m running into this problem as well. I have been flying Pixhawks with QGC for months and this never happened. All of a sudden it started this week. When I connect Pixhawk to QGC with microUSB, all the parameters download. But when I connect wirelessly using only telemetry, none of the parameters download. This problem also prevents missions from being uploaded. Something in MAVLink must be broken.

I have tried several combinations of QGC and PX4 but none work
QGC PX4
3.2.7 1.8.0
3.4.3 1.8.0
3.2.7 1.7.0
3.4.3 1.7.0

Every one of these combinations yields the same result.

I’ve gone thru as many forums as I could find, but there doesn’t seem to be an answer as to why this started happening. I’m running out of ideas… can anyone help?

Thanks,
Joe


(DonLakeFlyer) #3

Whatever your telemetry link is it’s either not working or very very noisy.


(Joe Marrone) #4

Since I get telemetry from GPS and all sensors, I know the radio works, which it has for many months. So if the radio works, why doesn’t the Pixhawk download its parameters? I thought it was a problem with some version of either PX4 of QGC but I tried all current versions and no luck.

If the link is noisy how can I test that? And would noise only affect parameter load but not telemetry data?

Still working the problem but no closer to a resolution.

Joe


(Barry Bolton) #5

Same setup for me. Problems only started after installing 3.4.3


(Joe Marrone) #6

Update. Thinking my controller was bad, I disassembled the F550 with the thought of replacing the controller. First I unplugged all the cables and substituted another controller, downloaded the firmware, booted up , and it worked, so I concluded the original controller was bad. Rather than ripping it out, I reconnected it again and proceeded to boot up, just to see what would happen. Lo and behold, now it worked!!! I powered down and booted up , and it still was working. So I left it in, put everything back together, and tested it again, and everything worked fine. I will fly it when I get a chance to verify performance.

I’m running PX4 v1.8.0 and QGC v3.4.3

Here’s my thinking: it is possible that one of the connectors was not seated properly, and by unplugging and re-plugging all of them, it removed any bad connections. Not sure what else may have been wrong.

For now, problem solved.

Joe


(DonLakeFlyer) #7

Unfortunately there is no noisy link indicator status shown. Something I hope to fix at some point. QGC has the data internally for it.

Noisy link is not easily seen in telemetry other than telemetry updates being slower than they should since some of them are lost. Whereas parameter download will fail after 5 retries, which can happen on very noisy links.


(DonLakeFlyer) #8

FYI: Mavlink packet loss was added and is available in Daily Builds: https://github.com/mavlink/qgroundcontrol/issues/6882.


(Joe Marrone) #9

I flew the drone Monday and all went well. Parameters downloaded quickly and missions uploaded quickly.

Don, I think your description “parameter download will fail after 5 retries, which can happen on very noisy links.” is what I have been observing, so I will not rule out that I have a noisy link, but obviously it does not always show up, and there are times when everything works as it should.

Thanks for the input.

-Joe


(Joe Marrone) #10

Update: The drone in question kept getting progressively worse until it would not work at all. I had to replace the Pixhawk 1 controller AND the 915 MHz radios. Both had failures. The idea that the telemetry link had a noisy connection was right on. It was so bad that I kept getting a repetitive “communication lost, communication gained” that would not stop. Now I think I have a working drone and will test it shortly.

Thanks,

joe