V3.2-rc9.Hexa will not keep ESC Calibration

I’m got my first build and it is a blackout hex. I set it up and I calibrated the ESC. It seemed good, motors spun up like it was supposed to. So I powered down, then turned it back on, armed hex and nothing hex will not do anything. I reset the hex several times, even re did the calibration, but got the same results.

I know the firmware I’m running right now is beta, but I couldn’t even calibrate it at all with the stable firmware.

Please help. I have been working on this for months, put it in the closet because I couldn’t figure it out, took it out again to give it another shot.


Have you checked your ARM failsafes such as GPS lock and HDOP and are you getting a green blinking light on your controller or a yellow light. Larry

I am having the same issue with my X-8 i just finished with configuring. When I power it on and try to Prearm it everything goes as suppose to except when I try to hold throttle down and rudder right fro 5 seconds. I have tripled checked that everything is in order but it will not initiate. It’s blinking green and gave me the sound that everything has passed checks but will not start the motors.
So I am thinking it must be the ESC calibration unless there is something in APM Planner I have done incorrectly. From what I can see in it is everything is connected properly and I have selected ALT Hold Mode. I am using a Spektrum DX7s and have all modes set in it but can’t figure out what I am doing wrong here.
I turn on the radio then plug in the battery and let it calibrate with the satellites then hold down the safety button till its solid red. Then nothing happens.

I have attached a picture of my Planner screen. I do not know what it means but there is a flashing red light by my flight mode.

Any help would be very much appreciated.

Thanks Mike

ESC calibration does not affect the flight controller, it affects the ESCs. When you put an ESC into config mode by starting it with the throttle high, and then you take it out by dropping the throttle low, it saves those endpoints.

APM outputs throttle with the same range as your transmitter does. Putting APM into ESC calibration mode simply passes your throttle straight through to all ESCs.

It is possible that your ESCs are for some reason not saving the endpoints. In addition, changes in temperature can cause cheap ESCs to lose calibration (and they tend to all do it differently, so you end up with a couple spinning and a couple not spinning). You can change the MOT_SPIN_ARMED parameter in order to get the motors spinning when you are armed but the throttle is down, and you should probably increase THR_MIN by about the same amount for safety reasons.

Hmm… maybe send a tlog? Is it possible your rudder is reversed? Try holding the rudder stick the other way, but don’t fly it with reversed sticks.