V2450GPS Fly Away

I had set a region of interest on my house and a circle waypoint around it and noticed it had trouble maintaining altitude and it was barely above the trees when it returned to the back yard for the last waypoint. It also had a little more trouble staying on the circle than my home build with pixhawk ever does. I should have stopped then and checked the log, but the low cost and lack of sweat equity made me too brave. I changed battery and before the controller registered a solid GPS fix, but after tower said I had 12 sats and 3d fix I foolishly launched it from my hand and put it above the trees, thinking it would lock in faster with a better view of the sky. I actively corrected it’s drift for a few seconds and it was still wandering a little when I looked down to check and saw that the controller light was now solid green. Thinking it was good to go, I looked back up and couldn’t locate the drone. This thing is much harder to see than my home built frame. A very short while later, Tower and the receiver both reported loss of connection.

I could still hear it for a short time but by the time I walked past the trees bordering my back yard, in the direction it had last been drifting, I couldn’t see or hear it anymore. I walked around my neighbors yards and eventually found a small area on a low rise next to a large wild area with small trees and lots of weedy brush where the transmitter reported telemetry was restored and that GPS lock was still established. I couldn’t see it in the sky or hear it or find it on nearby lawns or rooftops, so I assume it had landed in the weeds. My phone couldn’t see the wifi signal so even though the drone thought it knew where it was, it did me no good. I walked around the area hoping to recover the wifi signal, but the weeds and mud are nasty and I had no success before controller eventually stopped seeing anything back from the drone so I assume the battery cut out.

What went wrong and other questions:

I admit the home location which got set was probably less accurate than normal, but I wouldn’t think it was too far off since I had a 3D fix for several seconds before I launched. I don’t know if Tower updated home on the display when it reported home had been set. Does Tower grab the home location automatically or do I have to download the waypoints to update it and i was seeing home from the previous flight?

On a few earlier flights I had noticed it fly in circles in loiter mode. A few days ago, I did run through tower’s compass calibration procedure, thinking that was an issue. I’m not sure if that helped much. Does Ardupilot adjust compass calibration on each flight on the SV?

I didn’t change any other parameters except maximum transmit power (Does this do anything?) so it should have tried to return home at a safe altitude when the receiver lost signal. Also, what is the default geo-fence distance? That might give me some hints on where to search in the weeds.

I do own a self-powered FM beacon which I always fly on my larger, more expensive quad, but I’ve never had to to break out the phase-sensitive active antenna to find a lost drone and the SV is so light it seemed a shame to add any more weight to it. :frowning: I’ll order another SV and perhaps next time I’ll see how it flys with an extra several grams under the battery.

It will be dark by the time I get home today, but I may search a bit more tomorrow morning, though I doubt I will find it. Given the occasional circles, my best guess at what went wrong was that the compass calibration was still bad or the compass was misbehaving for some other reason.

Short of finding the little thing and looking at the log, any ideas on what went wrong?


A small update after searching in vain this morning. Turns out I didn’t have the micro SD installed on the last day after all. I found it in my SD reader this morning when I went to review some search video I shot from the big bird this morning. So, no hope of getting the logs from this flight, but I have the logs from earlier flights. I will check them for any signs of trouble from earlier flights.

I do have a crazy feature idea. I don’t know how often developers or sophisticated customers might able to get close enough to a lost SV to get telemetry from the transmitter, but not close enough for wifi. But, I suppose it might be possible to add a feature to send last known GPS coordinates back on the DSM link and read it by counting LED flashes after activating a special button sequence on the transmitter. Only the low order digits would need to be sent. I can’t see this being useful for most consumers, but I would have found it very handy on Sunday.

Hi Brad,
It would have set home at the location the GPS lock got good enough for the EKF to be happy, not at the point it got a 3D fix. That is the normal ArduCopter behaviour, but for situations where the pilot takes off before full GPS lock it isn’t ideal. Czar is working on a change that would monitor the GPS horizontal position accuracy and if it is reasonable at arming then it would use the 3D fix at that point instead of using an in-flight fix.
A new version of the SkyViper app would also have fixed this by allowing you to set home to the position from your phone (called “return to device” or RTD).
Unfortunately without either of those two things the home would have been set to the in-flight location, which clearly wasn’t ideal for you. Sorry you lost it!
Cheers, Tridge

Thanks Tridge,

I don’t think the home location was the entire issue. Based on what you said, I believe it would have been set while I still had it in sight.

The transmitter was indicating solid green when I looked down (Just before I lost sight of the drone) and I believe I also heard Tower report that the home location had been set just before I looked down and lost sight of it. I think the fact it was flying at about 50 meters and is so small contributed to my not being able to spot it again when I looked back up. I could still hear it for a few seconds even though I couldn’t see it. So I believe something else went wrong in addition to my foolishly taking off before I got the solid green light. It apparently had good EKF while it was still near me and should have set the home location near to the last place I saw it. It just drifted off for some reason even though it was in position hold mode with solid green light and it didn’t get back home when the receiver lost the signal. There was a some wind, but not more than the SV has coped with in the past. The battery was full to start and I’d say it was out of hearing range less than a minute into the flight.

The loss itself is not a big deal. The low risk of injury and the low cost of replacement is what is great about experimenting with this thing.
Sorry I don’t have logs from that particular flight for you.


Can you check if tower was logging telemetry to a tlog? The tlog would give us a lot of information on what happened

Tridge. Sorry it took so long to get to this. Yes, I put tlogs up on dropbox and emailed you a link. I hope direct contact for that purpose is OK. The privacy sensitive part of me didn’t really want the world to have everything in those logs. The last one seems to be the flyaway. I took a quick look at it and do see some indications of unhealthy EKF. The wifi connection seemed to drop before the GPS lock was good enough, but I’m still pretty sure I saw solid green on the transmitter after I lost sight of it and I definitely saw solid green several minutes later when I was wandering around trying to get close enough to the lost bird for a wifi signal.

I also did some cautious experimenting this morning with a different SV. It looks like taking off in “GPS” mode after tower is reporting a 3d fix, but before the fix is good enough for the green transmitter LED to stop blinking results in the flight mode changing from loiter to altitude hold immediately after arming. The way it is reported in the tlog made me think the transmitter made this change which seems bad. I think the green LED still blinks in this mode which is very confusing. Do the LEDs indicate the mode being requested by the transmitter or do they represent a mode received via telemetry? In my tests this morning, the flight mode switched back to loiter (and home was updated a second time) after the GPS lock met the requirements.

Once home is known, (It does seem to be set on takeoff even if the GPS fix is not firm), shouldn’t the drone attempt to return home when the transmitter signal is lost?

Assuming you have time to look at the tlog, any comments on what it shows?



Hi Brad,
Presuming that log_udp_2017_11_19_15_11_59_783.tlog is the right log, it shows that the SkyViper auto-switched to ALT_HOLD mode on takeoff as the GPS lock was not good enough for LOITER. At the time the GPS was reporting a horizontal accuracy of 91 meters, and a vertical accuracy of 111 meters.
The log only shows 30 seconds of ALT_HOLD flight before it stops. During that time the GPS accuracy didn’t improve (in fact it got worse). So at no point in the log did the flight board get a good enough GPS lock to set a home location.
I can’t tell what happened after the log stops, but it looks like it was having a really hard time getting a good GPS lock.
I don’t know why the GPS lock was so bad - maybe it was reflections off trees, or local RF interference, but with a lock this bad it really can’t do GPS navigation.
Cheers, Tridge

1 Like

I’ll be more patient waiting for the green light then!



I had a solid green GPS lite upon launch but noticed 2450 wanted to continue to bank in different directions without stick input. Switching to alt-hold the viper flew perfectly. Prior days the GPS would be solid and it flew great. Recycled the bird to see if it was a hiccup and the problem persisted. It would respond to stick inputs but there was a 3-5 second delay when it was acting up. Chalking it off to a bad environment. wish I could find an extra battery. Walmart sold out, Amazon is $43… Love this thing. $70 at ToyRuS sale.

I have several Solos with the first in 2015. Yep, I paid full price back then. Philip Rocks! Nice FC.

Throw mode to Auto mode mission
I don’t understand this Tlog re-play in MP. Green-light GPS Tx and 3D+DGPS lock in Tower as shown in these screenshots. Typically at least 10 satellites in this area but I don’t remember specifically.
Tlog 180705 Donald Park WI

Does Throw mode disorient the sensors? Why does the flight path stray so far from the actual mission location, including a squiggle over 1,000 meters away to the NE? Why is the Home flag set at the location where I spent most of the weekend? Why does the flight path include my location when re-playing the Tlog?

BTW thanks to Tridge and the many others who share knowledge here. It truly is a pleasure to fly Auto missions with the SV!

A flight log would be of more value.

Is that on the SD card or in Tower’s Android folder? Or download from SV via IP?

Right, from the Webserver App via IP.

1 Like

I have had similar issues , afew times with wonky GPS settings and a couple recently . I don’t use the Sv app much so I think not updating the GPS data often might cause the intermittent issues I have had . Plus sigoals can be bad due to sun activity , sat orbit and there are shadow times all over globe when number of sats is lower then normal or optimum . My sat radio in jeep has been wonky last few days as well . I try and remember to update GPS now before I leave house to fly as well now

Not sure if you’re aware, but Skyviper posts the GPS file daily right here.


You can just replace the UBX file already on your SD card

1 Like

Has anyone tried a UHF beacon? I saw one on the RC groups site slightly smaller than a quarter and a known good radio receiver was only $30. Small price for insurance if it worked.

Thanks Dave. I don’t see a BIN corresponding to that flight date and time. Several of the BINs filenames have incorrect dates. I’ll keep clicking.

This is sorta helpful but looking at the BIN in MP I understand little more than the map of the flightpath.

Can’t find a BIN for that flight screenshot I posted earlier, but this BIN from the day before suggests similar behavior: after takeoff as soon as I switched to Auto mode the SV beelined in a NW direction. On a larger map that vector points exactly where I’d just been 250 miles away (if I remember correctly RTL saved the day that time). hmmm.