UVC Issue with Tower?

Has anyone managed to get a UVC stream into tower working? I bought a EasyCap device with the UTV007 chip in it but i can’t get it to work with any of the android devices I own, on any viewer apps (Easycap Viewer, FPV Viewer) or the tower app. If you managed to get it working can I get the Vendor ID and the chipset it uses, so I can buy one of those to see if it works with mine.

The device does work when plugged into a PC and used with the supplied PC software (hones tech TVR 2.5)

You need to buy the one with “UVC” label, like: https://www.aliexpress.com/item/2016-USB2-0-Video-Capture-Card-composite-1-Channel-Usb-CCTV-Window-Linux-New-Arrival-captura/32656459858.html?spm=2114.13010608.0.0.AijP2S

It is different piece of HW. EasyCAP doesn’t work to me too, like:

I made same mistake… :slight_smile:

So im still having an issue with my UVC, this time the white one shows up at a UVC camera, and Tower and other apps recognize that there is a video input (Tower gets rid of the “No Video Availiable” text). But the image still stays black. For reference, I tried this with an android tablet running Android 6.0.1, and a Nexus 5x running 7.1.1.
I know the video input works because I hooked it up to a projector, it worked and when I change the connection to the device it doesnt work. Ill attempt connecting it to a computer soon and see what happens.

Ive found that plugging it into my computer gives the white UVC device to come up as USB 2.0 Camera and shows the image just fine. I just dont know why its not working with Android. Is it an android firmware issue or does the app not have the permissions for after Android 6.0?

Finally got mine working today. I went through three of these devices thinking the ones I was getting were not compatible. Turns out my Nexus 7 was only providing half the mA the device was taking when connected to my laptop, which was working great. I finally cut into a usb cable and measured the amp draw and sure enough the tablet was not giving it what it needed. I added another 5v source (I’m using a lipo and voltage regulator to power a BT module and telemetry radio in the same box) to the newly cut usb power source and it fires right up on tablet… Assuming any other 5v source would work too, like a powered hub, without having to make a cable. Any Android guru know of a setting to let more mA out? Sorry for the late reply, but I hope this helps someone. I searched for days…