USV with ArduRover & PixHawk4 - servo problem

Hello, all developers!
I am a new friend ad I have a simple USV with pixhawk 4 , ArduRover 4.0 official firmware and MissionPlanner as ground station control.
My USV is equiped with separated steering and throttle.
I am testing indoor in manual mode with Turnigy TGy 9X RC.
This side it’s ok and calibration radio it’s have completed.
I have linked a simple servo (steering simulation) at pixhawk power management board (see fig1 e fig2)

In Mission Planner Servo Output I(see fig3) I test all combination possible, but the servo non working.
If I use Servo4=SteeringMode the green bar does not move
If I use Servo4=RCin4 (my RC channel) the green bar moves correctly
But, in both cases, the Servo not working.
After three days of hard battle I ask for your help!
thank you so much for your help

Hi @frank_usv
I have encountered similar things before. At that time, I used pixhawk to drive a server gimbal. No matter how hard I tried, the server still couldn’t move. Maybe you can try to power the server separately and connect the positive and negative poles to a suitable power source. Try connecting the signal cable to the output channel of pixhawk, which was how I solved the problem at that time.

1 Like