Using Robotis Servos with Navio2

I have recently started using the Navio2 instead of Pixhawk.
I use a custom firmware (based on copter 4.0) and had no problem using the Robotis servos when I ran it on Pixhawk. I’ve tried building the same firmware for the Navio2 and connected the UART port (TX and ground) to the servo but it’s not working at all.I’ve checked up on AP_RobotisServo.cpp and it seems that it is unable to identify the port (port == nullptr).

I’ve attached the layout for both Pixhawk and Navio2.

I couldn’t find any previous attempts of using the Robotis servos with Navio2 and I’m still new to Navio2 so I thought I get some help.

Thank you!

hi @orewayoshi,
I am planning to drive Robotis Dynamixel ex106 servo motors with serial via pixhawk. But I’m getting an error in the servo test part in Mission Planner. Can you explain exactly how you powered the servos with the pixhawk?

Hello, I suspect that this implementation is not compatible with NAVIO2. Didi you asked on EMLID site?

https://ardupilot.org/copter/docs/common-servo-robotis.html

I only use the Mission planner for calibration and parameter editing. In the edited firmware I use, SRV_Channels::move_servo is used to move the servos. If you’re asking about the Vcc, I use an old version of the U2D2 power hub to power the servo.

Nope, the Emlid site was not as active as this forum so I thought I’d post it here instead. I guess Navio2 is incompatible just like you said. I’ll try asking the Emlid community as well. Thanks!

Hello!
What model of dynamixel servo you use?
This instruction https://ardupilot.org/copter/docs/common-servo-robotis.html is enough to make servo work with pixhawk?

I tried to control dynamixel MX-64 servo with pixhawk, but it didn’t work

Hi!
I’ve tested it with both AX12 and xc430-w240-t.
Have you updated your MX-60 to protocol 2.0?
And make sure you’re using ardupilot 4.0 and above.
(Both points that I have made a mistake on before )

The wiki page was mostly enough to make servo work.
I used a slightly edited firmware so I’m not too sure about the servo controls of a normal firmware though.