User Input Mission Planner Script

Hello all,
Does anyone know if it possible to trigger a SendRC value in the Flight Data Scripts of mission planner?
I am using a pixhawk 4 ArduPlane V3.9.6 with mission planner 1.3.63. Here is the code that I want to know if it is possible to user input the number 1 to activate the servo. If this is not possible, can you please recommend an alternative method to activating a channel?

while True:

Selection = int(input(“Type (1 + Enter) to activate servo 1” ))

if Selection == 1:

Much appreciated,

you can use the servo tab to do this in flightdata?
does it need to be channel 1

First off, thank you for the existence of mission planner!
It does not need to be channel 1. I tried using the servo tab with channels 5-8 and I have not had success with pixhawk 4 ArduPlane V3.9.6 .

I even ran a script to print cs.ch5-8in and cs.ch5-8out to print out the pwm values when I push the high/low/toggle buttons on the servo tab and I did not see any change in PWM values or actual servos move.

I have successfully moved all 8 channels of FMU_PWM_OUT Power management board + Pixhawk 4 using the sbus tx/rx and I have also successfully moved a servo Script.SendRC(Ch, PWM val, T/F,); however, my goal is to activate a servo mid flight without the rc remote. I wanted to utilize my telemetry with a command like a button or user input in a script. How can I troubleshoot to get the servo tab working. Is there a parameter that is associated with this in MP?

Below is my physical set up.


try your script with ch5-8out not in.

in is for RC input only. Out should change, but you might need to change the servo_options

There is no change in PWM Out values when I print cs.chXout, (where X is 5-14), and use the servo tab. I believe it is because I am using Holybro’s Pixhawk 4 with ardupilot. Do you know how I can troubleshoot this?

I am not an experienced programmer and I am a noob at mission planner but do you know where in Mission Planner’s source code the (flight Data>Servo) tab’s code is located?


It turns I failed to set the servo output to the correct settings. This fixed it

Silly mistake on my part (ー_ー﹡; )