Servers by jDrones

USB problem with uploading AP sketches to STM32 from Windows 10. And tips for speedy deployment?

Hi,

I’m setting up my toolchain for developing ArduPilot code in Windows 10 for deployment onto STM32 FCs over USB.

The problem I’m experiencing is when uploading to the STM32 FC. So, I’ll do something like this:
./waf build --target examples/INS_generic --upload-port /dev/ttyS10 --upload

The code will upload fine providing I power cycle the FC first (that’s the first problem). But the really big problem is that afterwards, Windows repeatedly loses/regains the USB connection to the FC every few seconds (with accompanying annoying chime sounds). I have tested it out on another Windows computer, and the same thing happens. Swapped cables, etc.

I have tried dual-booting the same Windows computer into Ubuntu Linux and the problem appears to be resolved. However, I really want to get this working under Windows (for various reasons I won’t trouble you with).

Has anyone else experienced this problem?

The second thing I wanted to ask is whether anyone has any tips for speeding up the uploading/deployment process.

Thanks :slight_smile:

I have solved the constant USB connection loss/regain problem. The code I was uploading contained a bug in a custom MAVLink dialect file I had made. I guess the board kept rebooting.

I would still be grateful to hear of faster ways to deploy the code to the STM32 FC though.

Thanks :slight_smile:

That is already as fast as it gets.

The trick is to do it less, test everything in SITL first.

Servers by jDrones