*Urgent* Ticking sound from Pixhawk 2

I recently bought a Pixhawk 2.1. I was working perfectly until today. When I powered the Pixhawk today, a continuous ticking sound is coming from the Pixhawk.
Unable to understand the issue. Please help.

@ppoirier Have you encountered this issue/any suggestions?

Check your input power supply. This usually happens when you have an insufficient input voltage.

Cut the red wire…

Edit: (uh don’t, bad joke…)

@Karthik_A Thanks for the suggestion.
I checked the input voltage. It was showing 5.4 V.
I also tried with by directly connecting using a USB cable. Result: Same behavior as with battery.

@fnoop Lol…

I have a couple of larger builds that do this if you try to power it from USB.
Just doesn’t have the current capacity.
So I have to power by battery then plug in USB.

You have given no details about your build?
How are you powering it?
Power module from where?
Does it hold 5.4V when the PH is ‘ticking’.
A photo of the build might help.
Have you tried using another BEC to power it up?

Also try unplugging all the accessories and see if it will power up by itself. Plug in one at a time until you find the problem.

@mboland I have attached a video.

Thanks for the suggestions.

I sent the Pixhawk to the retailer for repair. He could the find the problem but something was wrong in the cube. He replaced the cube and everything was working fine.

1 Like