Urgent Assistance Needed: USB Connection Issues with Holybro Pixhawk 4 Boards

I am writing to seek expert advice and assistance with a persisting issue I am experiencing with two of my Holybro Pixhawk 4 boards.

Recently, I have encountered problems with the USB connections of these boards. When I attempt to connect them to my computer, the corresponding COM port fails to appear as expected. This has been quite perplexing, and despite my best efforts, I have been unable to identify or resolve the problem.

FYI @mogu

Hi Arthur,
I’ve had similar problems.
I’m not an expert and my conclusions might be naive but I have found they work.
To others, be kind, I’m trying to help!

  1. Try another PC/laptop, the drivers might be compromised, this has worked for me.

  2. Turn your PC OFF then ON again, this has worked on a particular Notebook, I’m assuming the Ports are not cycled and need to be rescanned at startup.

  3. Don’t just unplug your USB cable when leaving Mission Planner (MP) unconnect using the TAB then physically disconnect, I’ve found this makes a difference, especially in the time it takes to reconnect afterwards.

  4. Look at the Computer `DEVICE MANAGER’ and see if the USB port changes when you plug in the UAV. If so, note the Port number and hope it appears in MP.

  5. AND, I’ve just had this happen, MP would not see' the FC and the PC Device Manager saw the Port for a very short time then ignored it. A report of No heartbeat’.
    Update your FC using MP. As instructed you don’t connect' go to Setup’, `install Firmware’. MP did see the FC and this, thankfully, revised an old faithful PIXHACK 2.8.4. as Pixhawk 1.

Hope this helps?

What operating system? Windows 10?

  1. Uninstall Mission Planner.
  2. Reboot, and re install latest mission planner. Installing Mission Planner — Mission Planner documentation
  3. Run mission planner but do not plug in the USB cable.
  4. Check the drop down menu and make a note of what com ports that are appearing inside the drop down.


  1. Now plug in the USB cable while it is connected to your Flight controller.

Do you see a new com port appearing inside the drop down?

If yes, select that com port and connect.

If that doesn’t work, unplug and try another USB port on your computer. Some old laptops have 1.0 and 2.0 USB ports.

If that doesn’t work, try another USB cable. Some USB cable believe it or not do not have all the wires connected to the connectors as some are designed just for powering up USB devices.

p.s. You must also have latest Windows Direct X installed on your computer.

If problem persists, post a screen shot of your drop down menu.

Thank you for your willingness to help. The actual problem was related to the hardware issue. Seems due to some short circuit it got damaged