Uploading Custom Firmware to APM 2 does not work at all

I have succesfully built Coax_frame based Arducopter on APM 2.8 a few months earlier using Arduino.

But from last few days i am trying my level best to get a coax_frame based copter firmware to upload onto my APM 2.8 board but it doesnt happen.

  1. When i compile on arduino, it is successfully compiled and i also get the .hex file in /temp folder but when i upload it to mission planner it says “Upload succeeded but very failed, expected 80 got 0 at 245760”.

  2. When i upload using arduino itself it successfully gets uploaded but when i open mission planner it says my firmware is a Quad frame firmware though i have very clearly edited the frame_config = Coax_frame part.

I know i should shift to more advance boards, but right now its a neccessity for me to use this AVR board only. Any help would be greatful.

Like explained many time is this forum, on boards from 2016 (APM 2.8) you need to use MissionPlanner from 2016.

Downgrade Mission Planner and retry.

I downgraded my mission planner to 1.3.36 which shows to be 2016 built.
Still the same problem persists, on custom firmware upload it shows UPLOAD SUCCEEDED BUT VERIFY FAILED

Any other mistake i possibly might be doing?

Probably you should not compile nor upload using arduino. You should use the ArduPilot infrastructure and upload using mission planner.

I am not sure what is exactly meant by ardupilot infrastructure.
But i have also tried uploading using Make on Windows & Linux and even there i am facing a error.
The error is on commanding “make apm2”, it says avr-g++ /tmp/arducopter.build/arducopter.cpp : fatal no such file or directory
Though the file exists right there in my windows explorer and even antivirus is temporarily turned off.