Servers by jDrones

Upload a indoor map

Hello
We are implementing indoor autonomous driving using beacon.
To do that, we need to specify the Way Point on the PLAN tab of the MP.
At this time, I would like to upload an indoor map instead of a satellite map.
Is there a way?

I always appreciate your help…

What coord system are you using. Fake lat/LNG?

If you georef an image you can load that into mp

Thank you for your answer.
I’m sorry, but I’m a beginner, so I’m not exactly sure about fake lat/Lng.
We don’t use GPS.
Deliver NMEA signals to Pixhawk from Beacon in Marvelmind to obtain Lat/Lng values.

have a look at this
https://www.qgistutorials.com/en/docs/georeferencing_basics.html

Thank you for your advice!
I followed the site you told me.
As a result, I got the .tif file.
The folder with the file was designated on MP through Inject GE, and the map type was changed to custom, but the map does not appear.

I will attach the original picture and tif file.
Thank you always for your help!

MAP TEST2.zip (21.0 KB)

when using a geotiff life this you use the “Custom GDAL” option
press Control-F > click “custom gdal” browse the the directory containing your image, click ok. restart MP
on the flightplanner tab change the map source to “Custom GDAL”
and move around the map to the location the image should be.

Thank you for your advice!
As you said, I succeeded in uploading a map to MP.
But every time I zoom in and out, the map looks broken, so can I know why?
I have attached a picture.
And is there a way to delete the uploaded map? Pressing Clear custom maps at CTRL+F does not disappear.
I will also attach the file uploaded to MP. Thank you…



TEST_MAP.zip (10.0 KB)

i think you need to correctly georef your image
image

MP is displaying what it was told. also, please try the latest beta MP, it fix’s a MP bug to do with this

Thank you!
Everything works well.

Servers by jDrones