Upgrading firmware on PixHawk (1) is getting difficult / impossible

Hi, over the last half year or so, upgrading PixHawk 1 flightcontrollers (3DR) and a clone version is becoming really hard.

It’s a quite difficult, to make the firmware flash, following the instructions on the screen.

Updating Params en pushing planned missions are working flawlessly every time, but loading firmware takes a load of attempts, sometimes succeeding, and during mij last update trying to get from v3.5.2 to v3.5.4 stable release it was not working at all.

I think I have tried over 20 times, and finally I managed to upgrade firmware on one of the drones by using QGroundControl (first try success)

The other drone however is not taking the flash in QGroundControl and Mission planner (tried with official and latest beta release)

Could this have anything to do with a old boot loader in these relative old units. (Jan 2014, and Sept 2014)

Or is this USB related ( running Win10 64bit system)

Anyone who has the answer here, I.e. do I need to flash a new boot loader before I retry flashing the firmware…or what?

Have obviously tried several USB wires as well, I.e they seem to work, during standard Mavlink communication…


Windows is never an advantage, and may cause lots of other problems. Serial is timing sensitive. A friend of mine had trouble flashing his android phone (needed to be done from Windows) and after giving up, we flashed it right away from a VMware XP on my Linux computer.

Anyway. If you tried good cable, try apmplanner2 or QGC on Linux.

There is no new bootloader, or known problems like that.

Ok thanks Andre, but I am still in the dark on the why…
Setting up VMWare and an image of XP to flash a PixHawk to me looks like hard for quite a number of users…, for me that means that I leave this drone at the current v3.5.2 (which is flying fine anyway)

can you please provide a copy of missionplanner.log
just to identify what might be going on.

the file is in c:\programdata\mission planner

1 Like

I do not suggest VMWare, just “another system”, in worst case, another windows.
That’s just in case something is messed up, we have all seen the strangest things that can go wrong in windows - most likely you have too.

So that was just me saying: if it’s not a bad cable (flashing seems to be a bit more picky about USB cables, likely due to higher current during flashing) - then just try different system/software.

I have never seen an APM1/2/Pixhawk/2.1 being problematic to flash, but had cable problems.

1 Like

Erik, I have always had such problems and I have never figured it out. It can be frustrating. But from a practical point of view:

  1. Try multiple USB cables, especially find one with a rf choke on it.
  2. Some laptops do not supply enough power on their USB ports, try a powered hub.
  3. Borrow another laptop with Windows 7.
  4. Make sure your SD is good and freshly formated.

Just things I have done in the past to get around the problem.

1 Like

Hi Michael,

Here you go…

Mission Planner logs.zip (381.9 KB)

As a matter of fact I started thinking that providing enough current (just like Andre was suggesting as well, I just see now…)
could be the case as well… So I used a powered USB hub between Windows laptop and PixHawk, and removed both Telemetry connectors… And guess what… Now it did flash…

Hi Mike,

I think I may have found it…
Try a USB powered HUB between PC and PixHawk, especially if you have a lot of equipment connected (2 x GPS, Both Telemetry ports in use)
The current to flash is more than your PC can deliver…

Thanks for your response…

Just fully reading your reply now… (Use a USB powered Hub) Indeed !

having telemetry radios plugged in while using usb I would say is also the cause of to much power draw from the usb port.

1 Like

Indeed…, I upgraded to two GPS’s also, and that’s taking away power as well…

So I guess this was more power related…

I guess there is no way to figure that out during the communication during the firmware update anyway…, (maybe the logs will tell you something you can use?)

The USB standard requires laptop makers to supply at least .5 amps per USB port. But some cheat and supply that for all their ports combined rather than each.

I can hit myself not thinking about this USB power issue earlier, as it is quite logical when you start adding more stuff that USB will have more problems to power that…and especially during flashing it does take more power than communicating over Mavlink.

The last couple of times I kept trying and trying, and sometimes it just took it, but the frustration knowing that you spend a lot of time to upgrade is killing…

Hopefully this is now a thing of the past…



Indeed. Good Luck Erik.

I have 6 Pixhawks, some made by 3DR, some from China. I have given up trying to flash new firmware using Windows 10 / desktop. Flashing is attempted with the Pixhawk in hand, not connected to anything other than USB (less than 100 mA current draw). I have an XP machine running Mission Planner 1.3.39 (latest version that is stable under XP), same USB cable, updates first try every time.

@Steven_Sarns whne it fails, are you selecting a comport from the menu before you try updateing?

Hi Michael, yes. USB com port. The Pixhawk connects every time via
Mavlink through the USB port, parameters are read and changes can be made.
But when I attempt to flash a new update, the system cannot find the
Pixhawk. I have tried plugging/unplugging as well as using the reset
button adjacent to the USB port. - Steven

I would like to chime in here to confirm that Flashing PH1 has become an issue.

In the process of updating a few controllers, I first did 2 Pixracers, with ease.
In fact I was a little curious that MP didn’t ask me to unplug them, just did the update without an issue.
I have a PH1 Octo on the build bench with nothing plugged into the PH so I thought I would do the update on it while I was at it.

No go.

Following the procedure of unplugging the PH1 when asked, clicking OK, then plugging the PH1 back in, I constantly got the board not found message and then the firmware failed message.
Updated to the latest beta MP (was running the latest stable release) made no difference.
Restarting the computer - no difference.

I did manage to get it to update by not following the procedure, but I tried so many combinations I can’t be sure the one that worked, but I think it might have been click ok/unplug/plug in or unplug/plug in/click ok.

One thing I noticed when following procedure, I was getting a lot of USB connect/disconnect chimes from Windoze.
At least 2 connects and disconnects.

Just throwing some info into the pot.

With a lot of windows usb chimes it might be worth checking your usb plugs and sockets. They are all poorly made and plugging them in and out spreads the “can” apart and sometimes makes the connections marginal. It may be that Mission Planner can’t complete the upload because there is a bad connection due to one of the four usb shells being worn.

I had the issues with my 3DR pixhawk and mission planner. I used external power through the power module and it updated successfully.