Upgraded telemetry radios to a multipoint network, now radios stopped sending data and Rover wont even achieve 100cm accuracy

Hello,

I’m working on a group project for positioning and orientation of an autonomous vehicle in an undergraduate research. We started using two RTK Surveyors from Sparkfun, RFD900+ as telemetry radios and the TOP10 Multi-band GNSS Antenna. However, we realized that, for better orientation, we had to use two ROVER’s and one BASE so that we could capture angular rotation of the vehicle.

In order to estabilish a multipoint network, we needed to upgrade the RFD telemetry radios firmware to RFD900x Multipoint SiK, everything worked well so far until we turned on the radios again and no more blinking red LED, meaning that no data was being sent nor received. However, we could see a solid green LED in both radios, meaning that they were connected. But without the red LED, we are not able to send RTCM3 data and achieve RTK service. Not even the ROVER surveyor itself was able to achieve 100cm accuracy by default.

We followed the setup that RFDesign has: change NodeID’s, check and sync comm frequencies but nothing worked. We went through some forums but no similiar problem was found.

We suppose that the problem is related to the telemetry radios, there might be some configuration we have missed that is not shown in in the RFDesign guide. Has someone dealed with this same situation before?

News:

I partially managed to solve problem.

We downgraded the RFD radios firmware to the original 1.9 SiK version so that we could go back to start in order to redo the steps to achieve a multipoint network.

After some continous tests, we discovered that it wasn’t a problem related to the radio but with positioning of the whole setup. We were testing on a building roof place which wasn’t that clear to sky view. When we changed to a parking lot, with better view, it was almost instantly how the radios started to flash the red LED!

So what we learned is that, for these radios, we need to work on really open areas with a clear view, or else we won’t be able be make the radios transfer information since they are not able to capture good data with the antennas.

Now we will try to upgrade the 2.6 Multipoint SiK firmware and achieve a multiple connection. We will come with more results.

Updated the radios again and two of them worked perfectly, with continous connection and data transmission. We followed the guide provided by RFDesign for multipoint setup by changing the radio’s Node ID and that’s where he encountered another problem.

We cannot use neither RFD900 Modem Tools nor Ardupilot Mission Planet to change the third radio Node ID. We set 0 for the Master Node, 1 for the first ROVER node and tried 2 for the second ROVER but a pop-up appeared written “Command Set Error”. We also tried using the AT commands by typing ATS25=2, then AT&W, then ATZ but nothing happened.

The third radio won’t even reach solid green LED, which means that it is not connecting. Has someone dealed with the same situation before? We suppose it might be something settings we still need to turn on.

Great news!

We managed to achieve multipoint network successfully!

We discovered that one of the radios was probably trying to connect to a previous one we used in our lab from another manufacture. It probably happened because another project was using one of the RFD900+ for a self-driven robot.

We had a fourth radio and decided to use it, upgraded the firmware and boom! All three radios were solid green LED and blinking red LED, meaning that all of them were connected and transferring data.

I will keep sharing our results in this forum so that future people with the same idea can follow up our progress.

Next step is to make a map using a library in Python called Florium and plot the geographic positions on it so that we can study how accurate our car is. To receive latitude and longitude, we will use another library called Pynmeagps.

1 Like

how to set master node I followed documentation but I am getting solid green only on master node module , all other module are blinking red and green light. what would be the missed step ? Can anyone help please?

Hi Shivam.

Sorry for not responding to your question earlier.

(Firstly, I am not an RFD900 expert and I do not work and RFDesign or Sparkfun, my solution might not be the best or it might not work)

Tell me if I understood correctly, only your master node is getting solid green LED, and the other radios are blinking the red LED but not solid green LED. Is that correct?

If so, I would like to know how frequent is the red LED blinking? Is it continuously blinking or it just turns on sometimes? Does it blinks ONLY when the green LED remains on for a short amount of time? How strong is the light?

I’m asking you this because I dealt with the same situation when the pattern of the red LED would actually mean it was receiving some data but not actually connected to anything. Weird, right?

And about the strength of the light, this is really important because it CAN tell you how is your RTK module/device operating. If the red LED is blinking a weak red, it means your RTK module is in ROVER mode. If the red LED is blinking stronger, the device is in BASE mode. I am not quite sure if this is how it works, but it was like that when using Sparfun RTK’s. If all your RTK devices are operating as BASE, this might be a hint about why your radios are not connected, because they will operate as a transmitter station, but not receiver.

Some things that need to be the same on all the radios which are very important are: Net ID, Air Speed, Frequency and Baudrate. Check these, because they set up the communication between radios. You can change these settings all on RFD Modem Tools, I recommend using that software because it is from the manufacture.

Now one thing that did not work for me but can work for you is to check for Node ID. The master node ID usually need to be set to 0. And then the other radios need to have different ID’s like 1, 2 and so on. Since I was working with RFD900+ which were built by the community, I could not change Node ID. But, for some reason, it still worked :stuck_out_tongue:

Check also your radio models. Some models are not compatible with each other by default because of firewall limitations. You can either check if there are compatible firewalls you can install, or you will need to buy new radios. I do not have much information about this.

Finally, check your radios placements. Bare in my mind these questions:

  • Is there any radio antenna close to my radios?

  • Am I testing the radios close to a wall or next to a concrete construction?

  • Do the radios have clear view of the sky? (When I mean clear, I mean REALLY CLEAR)

  • Are there any trees that might be obstructing the connection? (Just don’t chop 'em down)

  • Are the antennas big enough for the connection? Should I use one or two?

If you have further questions, feel free to ask!

In my honest opinion, the documentation is not that helpful. Because it offers a very brief and vague troubleshooting. I had to rely on forum posts and technical support to solve my problems. I do not know if you have rad them, but here are few links that a RFD technician shared:

You can also check on a more popular thread like this one: