Upgraded firmware … now cannot turn on motors

I have a Steadidrone 2014 QU4D with an APM 2.6 controller. It shipped with the Arducopter 2.91b firmware installed. Although it flew just fine by manual control, I was unable to connect it to the new APM Planner 2.0 software. So I decided to try upgrading the Arducopter firmware to the latest stable release (v3.1).

I loaded the new firmware, and then used the existing parameter file for the 2.9 1B configuration. It appeared to load, although it took several tries in order to update all of the parameters. Afterwards, the copter communicated correctly with APM Planner 2.0 software, and I get GPS/compass/accelerometer data through the 915 MHz radio. However, I cannot turn on the motors using the RC controller. I’ve tried without any effect:

  1. recalibrating the controller through the APM Planner
  2. reinstalling the firmware
  3. ESC calibration using the musical tones procedure on the APM controller (it doesn’t appear to finish calibrating).

At this point, I have a dead copter and could use some suggestions on how to get it flying again. Also, can anyone tell me where to download the old 2.91b firmware, so that I can at least resurrect the copter?

Thank you,

have you tried arming with mission planner plugged in on your pc?

It might flash up a reason for a pre arm check fail.

That did it… the problem was an ACRO_BAL_PITCH/ROLL (popped up in the messages as you suggested), which happened because the old parameter file I was using apparently had a different scale for those parameters. Also, the THROTTLE_FS was enabled … Now we’ll see what happens when I try to fly it with the new params.

Brill, good luck :slight_smile: