Upgrade to 3.6, no more airspeed sensor & plane dips left in FBWB/A


Helping a friend with a Pixhawk clone (rtfhawk). Upgraded to 3.6, now airspeed sensor is stuck at 5mph and does not move. pin is set to 65, and the airspeed + external compass on GPS are connected to the i2c splitter.

At a loss here - not sure how I can test to see if the airspeed sensor is actually broken or what…

Also seeing odd behavior where FBWA/B dips slightly left with no stick input (yes re-calibrated IMU’s)

Also tried:

-reflashing firmware

-replacing all i2c cables

-tried new i2c splitter

-Enabled/disabled airspeed sensor with power cycled in between

-cycled through all available settings for pin for the hell of it (left at 65 now as instructions state).

Any help would be greatly appreciated!

Hi all,

Same problem here:
If external compass is connected nothing no I2C component works.
As soon as the I2C compass is disconnected Airspeed sensor works again.
I tried moving back to 3.5.0. no luck…

Any helpp would be gratly apprecited!

Loaded AC 3.3. then AP 3.5 and everything works by default. so I loaded back the 3.6. Oh joy! still works.
Speculation: you need to have all I2C components hooked up when you load the FW.
Any DEV insight would be greatly appreciated!

update 2:
If system is booted without All I2C Components being connected components fail to initiate. Unfortunately it will not initiate even after reconnect.


on the 3DR GPS there is a small 3V rechargable battery “MS621FE” I am not sure what the purpose of it is, but if the voltage drops under 2.85V (2.5V unpluged), that is when you get I2C bus issues, slow GPS lock, max 6-7 satellites to fly with.

I have 2 GPS units and soldered in new batteryies in both, with measured 3V. (MEASURE BEFORE SOLDER!!! i was able t pick 2 out of 20 in the shop).

The result: Everything works on both! I have 8 satelites by the time I turn arround and press the CONNECT on MP and 10-11 by the time of takeoff.

This doesn’t really explain why the issue is only present with Plane 3.6, and how that by reverting to 3.5 you got this working. I have the same issues. Are you suggesting that by replacing that battery, all your i2c connected sensors are now working properly on f/w version 3.6, including your airspeed sensor?

I agree, but it worked and nowadays I am happier than curious so due to the lack of time I just went on to the next point.