Updating wiki for uploading firmware on PixHawk



I just started with PixHawk. Uploaded the firmware successfully AC3.4.4 via MP1.3.44.2, following wiki “http://ardupilot.org/copter/docs/common-loading-firmware-onto-pixhawk.html”.

I feel this wiki should be updated as MP popup messages are not aligned with wiki guidelines.

1/ I did not get this message as per wiki ==> " it will ask you to unplug the board, plug it back in and then press OK within a few seconds".

2/ instead, it started with “r u sure u want to upload…” , after pressing YES, it ended with totally new message “pls wait for musical tone to finish …”.

3/ I have not heard any sound as I have not connected buzzer / saftey switch / GPS etc. as it is not mentioned in above wiki.

I am attaching pictures and 3 sec video (for flashing LED in pixhawk after successfully uploading the firmware). click here for video

Kindly advice if an update require in this Wiki, following “http://ardupilot.org/planner/docs/common-wiki_editing_guide.html


Hi Adnan,

As Mission Planner gets updated it is possible that things change and the wiki gets outdated.

As you’ve gone through the process, we really appreciate if you can follow the Wiki editing guide to improve these instructions to be up-to-date.


Hello Farncisco Ferreira:

Thanks for your reply. I tried updating “common-loading-firmware-onto-pixhawk.rst” following “http://ardupilot.org/copter/docs/common-wiki_editing_guide.html”. All went well till step-5 where i started “Building/testing docs locally”, setup Vagrant successfully. Here i did the first build in my local PC (Step-3) without modifying any RST document, see attached “success_install_vagrant.txt”. success_install_vagrant.txt (370.3 KB) … All look OK…I modify the RST file with images (below snapshot)

…but after rebuilding, I am getting python update error “Parameters.rst: Permission denied” , see attached error_log_update.txt (66.3 KB)
(Note: I rebuild after placing modified RST file in ardupilot_wiki\common\source\docs\ and images in \ardupilot_wiki\images)

Modified RST file is common-loading-firmware-onto-pixhawk_rst.txt (3.1 KB)

How can i fix following error …


Please execute ls -l Parameters.rst in the same situation you had there.

My guess is that it is owned by root.

If it is, sudo rm -f Parameters.rst to remove it, then re-run python update

Hello Peter and All:

Parameters.rst file is not in /vagrant directory. Please see this log searching_Parameters_rst.txt (42.2 KB)

I looked into update.py script and found that script is attempting to delete Parameters.rst in /root directory. Since update.py is run as ‘vagrant’ user and doesn’t have permission to access /root therefore FAILED. I tried su - to change it to root user but asking for password … ?. I tried to captured this in this image

Am I the only person who is facing this issue?. I am sure whoever is trying to update the wiki via “vagrant user”, would be facing the same issue…correct?.

Pls. help as I feel that I cannot move forward without this password and authority issue.



OK, that’s a confusing comment. You can see in th epython code that it is not specifying a path when deleting the file - that means it is deleting the file in the current directory. The word “root” here means the “root of the wiki git repository”, I believe.

So. That wget is failing to write to the root of the vagrant checkout. From your searching_Parameters.rst.txt I can see this line:

vagrant@vagrant-ubuntu-trusty-64:/vagrant$ ls -lart
dr-xr-xr-x  1 vagrant vagrant   4096 Feb 10 18:35 .

So vagrant doesn't have write permission into /vagrant.  That's... odd.

Can you think of a reason that the "shared directory" `/vagrant` is not writable my its owner, the Vagrant user?

You *could* try `sudo chmod o+w /vagrant`, (to give write permission to the Vagrant user), but there must be an underlying reason that it is not writable.  Perhaps the directory isn't shared with the host and they don't want you losing changes when the VM is destroyed?  If that is the case, why are all the other directories writable?  You might check the directory permissions under Windows are sensible, I guess.

FWIW, the directory is writable on the ardupilot_wiki Vagrant VM I just brought up.

Try the chmod anyway and retry running the update.py IMO.