Updated from 3.2.1 flight mode selection and another problem rears it's ugly head

I foolishly updated my 3DR Pixhawk to the latest firmware (not Beta), and afterwards I was left scratching my head and pulling out what little hair I have left…
the problem is this… I did all the mandatory setup of hardware along with all failsafe and RTL switch along with the 3 pos flight mode.
when the Hexa is connected to MP flight data screen I can see that when the switch is thrown then STABILIZE -ALT HOLD-LOITER or RTL show up on screen…

However when I arm the hexa then only the STABILIZE -ALT HOLD will work and I get a double BEEP when trying to go to LOITER, and the RTL switch does nothing at all…

Now to cap it all the Pixhawk LED is always flashing AMBER after the initialization period is over… I am so pissed at this I went back to firmware 3.2.1 … bit of a pain really when an update causes so much hassle…

just discovered that this is “failing pre-arm checks” … I take it that I can’t select all flight modes or RTL when armed in MP until the Pixhawk has full GPS lock???

Each flight mode has a group of pre-requisites to be enabled. If these aren’t met than you can’t use it. If you try to start (ARM) on one of these modes and the conditions aren’t met, then the action is refused.

Also, pay attention because there are other reasons to refuse ARM. As an example, if you have a fence enabled (and the fence requires GPS) and you try to ARM without GPS lock, then the conditions for flight aren’t met and the vehicle refuses to ARM, regardless of the currently selected flight mode, and in this example even regardless of the pre-arm check mask.

nope… no go… Firmware 3.3.3 Hexa, I did all calibrations and setup… had full GPS lock and green status LED, no pre-arming errors at all… this just don’t work for me at all… it all works fine with no probs in firmware 3.2.1 , but what’s the point of having firmware updates if things don’t work as they should…!!! feeling slightly cheesed off…LOL

video of error beeps… switch error beeps

Please enable the full mask of logging, including pre-arm and post the log (BIN).

how the heck do I do that??? tough enough trying to get things working as they should…LOL




well… this is weird… I enabled GEOFENCE and all switches work as programmed…took it outside and all switches worked as they should (when armed, could hear the rpm’s on the motors change, and I never got the error beep)… brought the craft back indoors and disabled GEOFENCE and went back outside with it again (waited for blue LED and then green LED) all switches work in the armed state… wtf…! why then is MP showing that they won’t work (when craft is indoors with full green gps fix)… sorry to be a PITA here guys… I am an old fella and get confused most of the time…would you recommend enabling GEOFENCE permanently ???

without the pre-arm and arm logs, any tips are just guesses…

got it all working now… for some reason it won’t work properly indoors, even though I have GPS fix and the Green status light… works just fine outdoors…

you can have GPS fixes but high HDOP which can preclude arming.

aye, it all makes sense to me now… it was the fact that I couldn’t interpret that fact in Mission Planner… :rolling_eyes: