Unintentional servo movement when initializing the FC


I am currently building a scale heli with retractable landing gear.

I am using a Pixhawk Mini4 as the FC.

I have assigned a toggle switch to channel 9 on the transmitter to operate the retractable landing gear.

In the FC, input channel 9 is then redirected to servo output 5.

The power supply of the FC via the power board and the power supply of the servo rail are both supplied from the drive battery. Both power sources therefore receive power at the same time.

Now I have the following phenomenon: When I connect the battery and the FC starts up, the servos of the retractable landing gear first go to servo center and then a second later run in the direction I have specified on the transmitter switch.

Only the servos of the retractable landing gear behave in this way. The swashplate servos remain still or move to the position specified by the transmitter.

It can’t stay like this. It would mean that the model is ready with the landing gear extended and when the battery is switched on the landing gear jumps to the center position and then jumps back to the extended position.

I am attaching the parameter file here.
20231109_001 Bell 230.param (17.7 KB)

Not all parameters have been set up yet. I am currently setting up the model on the workbench.

Can you tell me how I can prevent or change this behavior of the servos? Thank you very much.



Use landing gear function instead of direct passthrough, then you will be able to configure startup behavior.

Hello Lupus,

Thank you for the tip. I have already experimented with this. But I don’t really understand the associated parameters. That’s why I was unsuccessful.
Could you give me more tips and information on this? That would be very helpful. Thank you very much!



Isnt it still a bug if direct passthrough is sending anything other than commanded?

Other than linking the documentation or parameter descriptions, not much without knowing the actual issue.


It defaults to trim value which IMHO is quite reasonable.

@heri Does your GNSS have a safety button on the top? The only way to get rid of this behavior is to use the safety switch. In this way you can energize the actuators after complete FC boot-up, pressing the button.
Look at the following params: BRD_SAFETY_DEFLT and BRD_SAFETYOPTION

Hi @Ferrosan

Thanks for your tip.

Yes, my GPS module has a button.
But my GPS module is invisibly installed in the scale body. I arm the FC with the sticks.

Apparently it is a problem to prevent the servos from starting up when the functions are looped through. I have read through the posts in the forum. The issue is probably criticized again and again.

In addition, I have set a time delay in the transmitter. This should cause the undercarriage to retract and extend at the original speed.
When I use the LGR_ parameters, the servos open and close quickly. I can therefore use the LGR parameters, but then I can no longer use the original speed.

If the forum has no other solution, then I will loop an extra mechanical switch into the power supply cable of the landing gear servo. This way I can prevent the servo from moving incorrectly.

It’s not pretty, but it’s probably the only practicable solution.

I keep realizing that Ardupilot is designed more for copters.