Servers by jDrones

Unhealthy GPS Signal

Hi there, I’m new to Ardupilot/RC flying in general.
Please let me know if I’m not posting this in the right board.

We’re getting the error message “Unhealthy GPS Signal” in Mission Planner. We’re using a Matek F765-Wing - Ardupilot 4.0.6 with a Matek M8Q-5883.

I’ve tried looking up similar issues and can’t find much.

I’m leaning towards thinking we just have a bad GPS module.
No matter what I do HDOP is always 99.99 and we never get a fix.
From what I’ve read unhealthy gps usually means ardupilot isn’t getting a consistent 5Hz signal, but in the log GPA.Delta is a consistent 0.2, which is what its supposed to be, I think.

Here is my .bin file: https://drive.google.com/file/d/1NkFat9a5uYRHi22JCzVQdYjxT5v31iqI/view?usp=sharing

Does anyone have any ideas?

Good day, when you are using a gps module just mount it on a stand and far from antennas… vtx… receivers and cables.
just perform if its possible the calibration outside.
in case after you perform the calibration you will see a high offset just disable the compass and set the one with the best value.
You can also shield your module with a special tape

We’re still building the plane, so when testing we have disconnected everything but the gps module and telemetry, and they’re as far away as possible from each other. However it is sitting on the (plastic) wing, does it need to be away from that too?
I didn’t realize it had some initial calibration time. How long should it take to calibrate? We’ve tried leaving it on outside for 5+min.

for compass calibration its necessary rotate the vehicle randomly… you can also set how strict you want perform the compass calibration., don’t forget to set automatic offset before perform the calibration if you don’t have installed the module with the arrow in the same direction of your fc.
Just use MP for calibrate your compass

You have a problem with GPS not the compass right? This must be so as you haven’t calibrated the compass. GPS is not “calibrated” but it can take some time to acquire sats initially. Try setting the GPS_GNSS_MODE to 1.

Thanks for the advice! Yes, I’m having issues with GPS not the compass.

I changed GPS_GNSS_MODE to 1 as you suggested and it seems to have helped.
It had to leave it outside for a good 5-6 minutes before it got a lock and it doesn’t work at all inside. Is this a normal amount of time?

It might have made no difference but I’m not sure how the M8Q is “currently configured” which was the default. Forcing it to “GPS” (1) I thought might work. More time than that even when initially getting sats. Leave it outside for 20 minutes and then restart it inside and see if it’s working.

Also, try changing GPS_GNSS_MODE to 67 and see if things improve. The FC needs to be rebooted after making these changes as the GPS configuration is written to the module on boot.

Should I expect to wait that long every time I want to fly?

No. It should acquire enough sats for lock in less than a minute.

The documentation for the GPS module says it supports GPS, GLONASS, SBAS, and QZSS, so I enabled all of those in GPS_GNSS_MODE. 90 I think. Reboot and set it up outside for ~20min.
It still takes more than a few minutes to find any satellites and it only works inside for a few minutes before losing all signal. The most I saw was 7 sats.

We live pretty close to some big power lines, so maybe that’s causing too much interference?
It didn’t seem super accurate when testing outside, it was jumping all over the neighborhood.
I haven’t tried near where we’re going to fly because we’re still waiting for a few parts, but hopefully it’ll work better there.

Thanks for your help so far

You don’t want that many satellite constellations with Ardupilot even if the module supports it. Try 67

67 it is then. Is having too many constellations just too much for the FC/GPS module to handle?

Testing this morning seems to have gone better. It still took a while to get a fix, but once it did it seemed a lot more accurate.
I brought it inside and it managed to keep a fix on 4-5 sats for a long time. After a quick reboot it manages to keep the signal lock but if I wait a minute or two it loses it and I’d have to bring it back outside for it to lock on again.

I think I’m ready to call this good enough for now. We’ll see how it goes when it actually flies.
Thanks for all your help!

It may not meet the sample rate that Ardupilot needs with too many selected. If there is a battery on that module perhaps its dead.

The chances GPS works indoor are close to zero. Always test GPS outdoors.

Servers by jDrones