"Unhealthy GPS signal" message while board arming, 3D-Fix with 10+ sats is stable

Problem description:
Every time I arm my board there is a message «Unhealthy GPS signal» shown. This message dissapears after 3-4s after arming is done. There is stable 3d-fix with more then 10 satellites achieved nevertheless. This message does not appear while disarming, GPS-positioning seems to work stable with no respect to armed/disarmed status.

Equipment configuration:

  • Matek F765-WSE under Ardupilot 4.1.7 (checked down to 4.1.4)
  • U_Blox M8N GPS module (with compass).
  • 3DR radio for Mavlink connection (433MHz, 20dB power)

Parameters of U_Blox M8N has been reverted to defaults through u_center. M8N corresponding parameters set in MissionPlanner:

  • GPS_RATE_MS == 200ms(5Hz)
  • SERIAL3_BAUD == 38 (38400) (230 (230400) was checked also)

Has anybody struggled with something similar?

What is the actual message?

“Unhealthy GPS signal” - sorry for mistyping.

This may be due to hdop being too large, but I’d expect there to be a message reporting that also. Maybe it’s in the messages tab on MP.
This is the wiki page on GPS prearm failures, but it doesn’t list “Unhealthy GPS Signal”:

What does GPA>Delta report in the log?

And forget about using U-center for configuration. It will be overwritten anyway on boot from Ardupilot. Configured everything form Mission Planner.

Excuse me please my unawareness - could you please tell me how and where to find this report?

This was suggested by Matek support specialist.

No, nothing about HDOP at messages tab. I also tried to set GPS_HDOP_GOOD to 2.5 - no result.

I’ve found where to find this information, thank you very much. Unfortunately I will be able to get necessary data on the next weekend only. Upon information is available I will be back with it here.

Just in advance - what kind of data I have to look first in this report?

Update rates slower than the GPS Update rate in ms set (GPS_RATE_MS).

@dkemxr I guess that this will be the root course of the issue. But how this problem can be solved if my guess is right? GPS_RATE_MS is set to 200ms (5Hz) in my configuration.

In fact, developers do not recognize this error - as I understand it, there are terrible problems with threads - periodically threads interrupt each other in time because of this, this error occurs!

I also suppose that such a behavior could be a consequence of thread races. If GPS signal was really unhealthy then this message should be present all time but not for 3-4 sec at arming invocation only. I will check GPA deltas report on weekend to confirm or disprove this guess.

Do you have any more information about thread contention issues? (Links to discussions, etc.) This seems like it would be a big problem.

I was having this issue and it was driving me nuts. I would get fly-away’s that would result in crashes and unlike you I would get 3-4 Sats. I spent a lot of time trying to figure out what was happening and what I started to realize is that shielding the antenna is key to the whole thing working.

I put a metal “ground plane” under the antenna (which is mounted about 4 inches above the deck) and it helped, I got more Sats but I would get the GPS Unhealthy message after arming. That seemed to indicate added interference from the ESC’s and/or motors. I looked around for a quick fix, something that would shield the sides too, and I found this metal can. I stuck that to the top of the mast and put the antenna inside of it. So far, I’ve had good results. I’ve gotten more Sats than ever before - goes between 11-13, and for the first time I see 3D dgps instead of 3D Fix.

The can I am using is too big and looks terrible, I’ll be finding a more elegant solution soon.

This method works well

1 Like

This is not a my case - I have 12+ sats even indoor and 16+ outdoor independently of ESC and motor current. There is no GPS Unhealthy message in flight, only for 3-4 sec after arming.

Do you have anything plugged in the USB ports of the raspberry under the navio?

Nope, not a thing plugged into the RaPi USB ports. I tipped the telemetry radio forward. I started to notice that the vehicle, sitting on the launch pad soaking up satellite signals was fine, but as soon as I went to ARM it, the GPS Signal unhealthy message would pop on the screen. After disarming, the message went away.

Check the 5V power supply, GNSS receivers are very sensitive to that.
Does it sag when armed?

I got the same error in 2 separate systems while in Italy.

Pixhawk v1 with vr Robotix GPS ( m8n) running latest stable arduplane and
Cube black with here GPS (m8n) running latest stable arducopter.

Both system prior to this episode never had this issue and a part for minor firmware update, no other changes.

I flew each system in 2 different locations with same results.

20+ sats and hdop lower than 0.8. copter shower the issue while in flight while plane on ground. Both system were absolutely stable in flights and very precise.

Maybe something due to current ongoing situation in East Europe ?