Unhealthy AHRS?

Curious what this actually means - getting good nav performance, no yellow on the EKF or vibe, and running rtk Fixed!

1 Like


Normally the “Unhealthy AHRS” only appears at the beginning soon after startup but before the EKF has a position estimate. It’s on the to-do list to remove this message (in this case) because the AHRS isn’t really “unhealthy”, it’s just missing a position estimate and it has other messages to report the same thing.

If this message is always being displayed then it could be something important like an accelerometer failure or the EKF has hit the limit of how much it can change the gyro bias which can be caused by large changes in heat between startup and later on. If you have a log I can have a peek.

We are getting it almost continuously.

I have a vague memory of a need to reboot once the autopilot got up to temperature. Is that still a requirement? I’ll have another look at our logs and see if it’s only showing up on the first log of the day - we haven’t been doing a reboot after it wamrs up.

I’ve looked at two logs - one from startup, the other after a reboot, and both showed it.

It’s a Cube Orange.

Tlog or dataflash?


Normally a reboot after warmup is only required if the ambient temperature is very cold. I can’t say exactly how cold but I would guess it needs to be below zero.

A dataflash log would be better.

Hi Randy, I sent you a log a few weeks ago - did it come through? We have a demo coming up next week so would be good to get rid of the scary red error message!

Hi @mroberts, I had the same problem with the two different rovers I am buliding, in my case, was the accelerometers calibration. I only did the “simple” calibration (placing the rover flat and level), once I did the “full” calibration (on every edge) the message went away, in both of them.

1 Like

Ahh, darn - we have the autopilot installed in a large vehicle, and I’m reluctant to pull it out to do a calibration. No way we can turn the vehicle on its side, but I’m assuming (unlike compass), that you can do a calibration with the autopilot out of the vehicle?

1 Like

I’ not an expert but I would say that it can be done with the autopilot out of the vehicle, as calibration takes into account the internal noise and offsets of each accelerometer at different positions against gravity, so it should not be affected by the frame, I guess. With compass, nearby cables do affect the offset a lot, so having the frame with all the cabling is a must.
Good luck!

1 Like


Sorry for taking forever to review the log.

The “AHRS Unhealthy” message can appear for one of two reasons actually:

  1. the accelerometer calibration has not been done ← this is the cause in this log
  2. the vehicle has no GPS (not the case in this log)

Similarly, if the gyro calibration (run soon after start up) fails a “Bad Gyro Health” message appears on the Mission Planner HUD. This often happens on boats that are powered on while already on the water. This known issue has a workaround documented here on the wiki.

By the way, in the logs the ARMING_CHECK parameter has been set to zero. If this had been left at “1” then I think a message something like, “Accel calibration required” would have been displayed when the operator tried to arm the vehicle.

Again, sorry for the delay, hopefully after performing an accelerometer calibration the “Unhealthy AHRS” message will go away.


Thanks Randy, that did the trick - we had to pull the autopilot for maintenance and it looks like that’s solved it.

I’ll review the arming parameters - probably would have helped if we’d had them on.

Unhealthy AHRS is back, out of the blue.

Good GPS signal - 3D Fix 14 satellites
Accelerometer calibration - Done

No change.

Any ideas to just turn this bloody thing off completely?

1 Like

Why on earth would the same message appear in the Ardupilot Simulator? It’s got a simulated IMU etc so should NEVER give “AHRS unhealthy” message, bizarre!

I have no idea about how it can happen in sim! That is strange. My understanding at the moment is that the error can be triggered by gps not sending data at the 200ms (5hz) intervals. So even if you have 3d fix or rtk and 14 sats, if the gps is at its limits of doing the calcs and providing the position data (especially with multi constellations etc) it may be late reporting the nema and then you get ahrs not healthy. I feel its a kind of watchdog timer expired alarm

I can confirm the temperature issue. We have a heatwave at the emoment (up to 38 Celsius) and our large rover (80kg) heated up considerably. We can’t use the magnetometer as it wouldn’t do anything sensible close to or in the rover, calibration never succeded. No wonder with all the sheet metal and big motors around. So we estimate the heading via GSF, which works considerably well. Suddenly I got the AHRS message, couldn’t make it go away. However, GPS was brilliant, EKF variance could be deleted by driving around a bit. GSF_RST_MAX is on 10 (I don’t know why the limit there is so low)… I would guess, it is GSF_RTS:MAX due to temperature changes. Can I somehow log the reset events of GSF?