Unhealthy AHRS and Flight mode change failed

I have a problem with my Cube Orange. It keeps showing me Unhealthy AHRS.

Can anyone help me? The log file can be found under the following link. Logfile_Rover

@Donaut Do simple accel calibration.

Thank you very much for your help.

I have already done it and have done it again, unfortunately without success.

Is it possible that it is related to the GPS?

The GPS is currently missing the direction information, hence the message. Drive/run a few meters, then the message is gone.

1 Like

I had this same message and fixed it tonight by doing the accel calibration. It had failed every time I tried it before but tonight I read another post that told me the last instructions say to place it “back” which I had assumed was back level on the rover. It’s actually asking us to flip the pixhawk/autopilot over on its back, upside down. Once I did this it completed the accel calibration successfully.

I hope that this instruction can be changed to more accurately describe what is being requested in future releases. Hope it helps you too.