Unfortunately, Droidplanner has stopped

I think this falls under device support… Proscan PLT-7035 C

I bought a small 7" tablet to try to run DroidPlanner. It supports OTG cable for USB (powers my 3DR radio, I can read from a USB flash drive plugged into it)
It runs Android 4.1 (with a strange Aptoid app store beast instead of Google Play)
I installed DroidPlanner V1.2.0 from the store and I get the dreaded
"Unfortunately, Droidplanner has stopped"
immediately on launch.

I re-installed… same
I cleared App data… same
I went to the GitHub repository for DroidPlanner and installed V2.1.1 RC1 and got the same result.

Attached is a log file that V2.1.1 RC1 created found in /DroidPlanner/LogCat

I did some poking through the log file and I see the following error in the log that I think is related to Google Maps. I can run Google Maps on the device.

java.lang.RuntimeException: Unable to start activity

Caused by: java.lang.NullPointerException: IBitmapDescriptorFactory is not initialized

Looking at other web pages I see that this may be related to the way the App initializes Google Maps or it may be related to Google Play on the device… I am thinking the latter because… this device does not have Google Play… but searching more it would appear that it is more related to Google Play Services which it does have, but I installed the latest Google Play Services anyway and… same error…

There are hints at
stackoverflow.com/questions/1393 … ized-error
that using
Call MapsInitializer.initialize(getApplicationContext()) in the onCreate()
might resolve the issue… but I am over my head…

So, is it my Google Play services? Is it because I am missing Google Play? Is it because of the way DroidPlanner initializes Google Maps?

The problem probably lies in that your device doesn’t use Google play services in a standard way. It’ll be very hard to debug this online, so I’ll not be able to help.

There are two ways to go from this point:

  • Poke around with the code, and if you find a solution submit it to me that I’ll integrate it in the main source.
  • Buy another device, I recommend the Nexus 7 2013.

I had the same problem on a Chinese tablet that did not run / work with google play. I did get DP to work though. Use Aptoid and search for google play services app [ might just be google services I forget ]. Install that app. It will install it but won’t run. However… because DP seems to see it now or something DP then works! I think it’s because without seeing that it doesn’t think it will be able to load map tiles. Just a guess. But who cares it works. Aptoid works really well I thought.

Unfortunately govsuz that was one of the first things that I did. Downloaded and installed Google Play Services using Aptoid. That did not resolve the issue.

I took the easy way out on this one… I returned the tablet and bought one that was just as cheap but this time I actually tried the app in the store. The new tablet is an iview 754TPCII and for Droidplanner it has some real advantages over the one I was struggling with. $69. Two cameras vs 1. Both micro USB for OTGUSB and a power jack so I can power it AND have the OTG cable plugged in. Supports Google Play. Android 4.2.2 vs 4.1.1… and best of all… it just works…

So I am considering this one closed… Proscan PLT7035-C is a no go. iview 754TPCII is a functional low end tablet that just works.

The only other thing I might add is that on my old HP touchpad that worked and on this iview tablet that works, the very first time I ran it on both, I got the Unfortunately, Droidplanner has stopped message, but both times when I ran it again it worked… not exactly sure why it fails first time. If this is something Arthur wants to investigate my tablet is in a state where I can torch it and start fresh and see how/why that happens…

Good to know. I had one of these and worked great with DP after installing google play services. But as mentioned above it did not actually run the google play store but as long as it was installed DP worked just fine. ebay.com/itm/TravelTek-7-Inc … 35d19c253c

But if the one you found actually works with google play thats a bonus!! Good to know there are tablets that can work for under a hundred bucks! It’s a lot more of a carefree trip to the flying field if your not carrying the latest $350 tablet! On a similar topic I use a Mobius camera. If it gets lost or destroyed it’s only $75. My brother just lost his $1000 Dji Phantom and $300 gopro OUCH!!! If he would have had APM and telemetry to a $75 tablet it would not have happened. He got too far away… disoriented… forgot what mode it was in… fly away…gone. :cry:

Hello guys,

The newer versions have a check to see if you have the Google Play Serivices installed, and should display a warning if you don’t (instead of crashing).

[quote=“arthur”]Hello guys,

The newer versions have a check to see if you have the Google Play Serivices installed, and should display a warning if you don’t (instead of crashing).[/quote]

So if its crashing immediately on startup and still giving the “unfortunately droidplanner has stopped” error we can assume its not google play services related then? I’m having this error on an HTC one m7 phone.

The latest version is now crashing sometimes while I’m using it. It didn’t do that on the previous versions. It only happens once in a while at different times. I have an ASUS 10 inch tablet with keyboard.

Mine is crashing immediately upon opening on a htc one.

Here first generation Asus 7 has crashed twice, both flights when it has been in use. Radio is RFD900 and APM 2.5 modified for external mag.
Once I had a message “Unfortunately, Droidplanner has stopped” and second time it was crashed without notice (after flight I didn’t see any message).
Also distance to home doesn’t update. It has some distance taken at some random point and keeps it over whole flight.

Android and Droidplanner are latest two days ago. Crash reporting is in use. Internet is through mobile phone WLAN.

Three flight with Droidplanner are done and Droidplanner has crashed three times.
Last time Android wrote a message “unfortunately Droidplanner has stopped” and same time I heard something “… check connection”. It was about the radio link. But it happened after Droidplanner crash.

My co-pilot said he saw first crash report and then heard voice. This happened about 9 mins from take off.

Any ideas what is a problem?

My acer tablet crashes the same way. The latest update seem to break the app. I wish I could go back to the older version.

Are here developers reading this thread?

It looks like there are more users experiencing crashes.

If this is known issue and under investigation, please let us know.
If there is something we could do for helping investigations, please let us know that also.

I’m willing to provide any information developers might need if just be guided what to provide.

Just made quick Googling of this issue. There are more mainly older threads of crashes, but they seem to be related program startup.

I experience crashes after minutes of flying. This is more difficult as you can’t trust your only change to get information whether autopilot was engaged automatically or not. Startup crash is better as then pilot knows not to take off. My heavy DSLR copter crashed badly twice because Autopilot got an error and engaged RTL which caused full speed (way above normal autopilot speed) flyaway and collision. Tablet is only indicator that autopilot is engaged without pilot request.

I found this kind of question list from Github:
Have you used DPv1.2 without problems?
Can you use the Google Maps app?
Check the /DroidPlanner/LogCat/ folder in your device, and copy and paste any TXT files that you find there to the post (those will help us to diagnose the problem).

My replies for these are:

  • This latest is only version I have used
  • earlier yes, I’ll check this date state later today
  • I’ll post it after work (morning here)

Is there something else?

My radio is RFD900. APM is 2.5 mod to external mag. Tablet first gen Asus Nexus 7. Android latest.